Biped: Setting planted keys


#1

Can someone explain something to me, because it bugs me to Hades…

So, I’m using Biped to animate a character, specifically a walk.
But whenever I try to set a planted key of, say, a foot…it moves. I click “Set planted key”, expecting that the foot will stay where it is, but no…as soon as I click, it goes haring off to some totally unintended point, and for the life of me, I have no idea why.

I’ve tried other methods of setting keys: moving the foot while Auto-Key is on, toggling ‘Anchor Foot’ (which usually sets a key all by itself, but not the one I want, and I still get the same problem if I try to set a planted key while the anchor is on), and pretty much everything else I can think of.

So, I’m sittin’ here thinkin’, “C’mon, MAX…! Behave!” The Help files are, well, not helpful; they seem to imply that things would work as I intend, and don’t address this problem at all. I d’know…is this a bug or a feature? How do I accomplish what I’m trying to do, here: setting a planted key with the foot in its current position, without it moving without my permission…?


#2

You most likely have already set another, earlier planted key and CS tries to keep that in place. You’ll have “release” that one first. (Might be that is added automatically when first adding a planted key).
Anchoring (as far as I remember) is a temporal tool, that should not set a keyframe unless you do (directly or via auto-key).


#3

Hrm. Sounds like a case of MAX trying to be too helpful.

Ah, well. Thanks. :slight_smile:


#4

There are three kind of keys:

  1. Planted Key: It keeps the position of a previous key. IK-Blend is at 1.0. If you expand the IK rollout you can see the option ‘Join to previous key’

  2. Sliding key: IK-Blend is still at 1.0 but does not inherit the position of the previous key.It can ‘slide’ therefore the name ‘Sliding Key’

  3. Free key: IK-Blend is at 0.0 and you can freely place the limb where ever you want.

So for a foot roll:(Pivot can be set in the IK rollout->Select pivot.)

Free Key (foot is in the air)
Sliding key (foot makes contact with ground. Preferable the pivot is set to the heel of the foot)
Planted key (heel goes up, pivot is set to toes)
Free Key (foot is in the air)
…and so on

It`s a really easy to use and very intuitive system


#5

Thing is, I’m not only still encountering this problem years later, but it’s got nothing to do with not understanding how each key works…the problem is that they’re not working as advertised.

It doesn’t matter what kind of key I set, it doesn’t matter what the IK-blend is set to, and it doesn’t matter whether the Biped object is set to ‘Body’, ‘World’, or a specific object…they key behaves like it’s a free key.

Worse, no matter what I do, that particular key will behave in this fashion. I can even copy-paste another key and, in doing so, it will change the sort of key it is. More than that, it’ll change other keys around it, too, almost as if MAX has decided that keys can only be of a certain type and in a certain order.

And sometimes, when I copy a key by selecting, Shift-Clicking, and dragging, a few other keys that were never selected will come along for the ride; this only happens with Biped keys.

I’m utterly boggled, and it’s really getting in the way; I’m on shot #94 right now…