Big problem with Directional Light on Viewport, need help urgently


#1

Hi,

First of all, English is not my native language so I’ll try to do my best to be as understandable as possible.

So here’s the thing. For my final exam, I made a maya animation project wich uses specific FX, forcing me to render by the viewport directly. So I don’t use Arnold renderer, or mentalray, or redshift, or any render plugin because I directly render from my viewport with specific materials on my items.

So far, no problem with this. But, for a big scene that takes place outdoor during the day (sun almost at zenith), that’s where the problems start…

when I put a directional light on my scene, the shadows are like pixelart on the ground. Basically I have two choices :

  1. My whole scene have a shadow but it’s super pixelisated,
  2. If I reduce the shadow focus, just the center of my scene will have good shadows but all the rest around will just don’t have any…

I put the shadow resolution at 4096, but because my scene is “big” (my scene is actualy tiny because it’s not upscaled like in 3dsmax, and because I work with specifical FX materials, I cannot upscale it in any way or it will ruin my whole scene), the auto focus that takes the entire scene look like pixelart, and I cant go upper than 4096, on the viewport nothing change…

I made an exemple of my scene with a ground and some spheres with antenas :

  1. https://imgur.com/vFRVNEp Here, with the auto focus, we can see every spheres have shadows on the ground (but not the antenas on the spheres).

  2. https://imgur.com/XirYwb7 Here, with the shadow focus manually set at 10, I have a good shadow under the first sphere, but everything around don’t have any shadows, also the shadows under the antenas still missing.

  3. /h0ZXE8Q (I can’t post more than 2 links so just replace the imgur code) Finaly manage to have a good shadow under my first sphere with the antenas shadows by setting the bias at -0.0010 but everything around still don’t have any shadows… (also, on this exemple it works, but it’s an exemple, my real scene have way more assets in it and modifying the bias at -0.0010 looks way worse…)

I’m begging for help, I’m not a pro in Maya software and I can’t go any futher without solving this light problem… Is there any way to force the directionnal light to use a shadow resolution upper than 4096 on the viewport ?? Or a plugin/script that allow me to use better directional lights in my viewport ??.. or any alternative ways ?..

Thank you from the bottom of my heart to anyone who can help me…

PS: First time posting here, I hope my post follow the community guidelines correctly.