Batch render hangs and never gets started


#1

Hey everyone,

  I've got a scene in Maya 6.0.1 that refuses to batch render. It's a pretty simple scene, consisting of a few low poly models (with the "use background" shader applied) and a 3d fluid fire effect. When I render a current frame, that works fine and fast... less than 5 seconds. When I try to batch it, it never gets started up. I get the following:

// Result: Rendering with Maya Software… //
// Result: Percentage of rendering done: 0 (starting) //
// Result: Percentage of rendering done: 0 (doing frame 1849) //

…and it just sits there, staring at me.

Does anyone know what could be wrong? I’ve cached the fluid, just to be safe, and it still doesn’t work. Any thoughts?

Thanks in advance.


#2

possible memory insufficiency? memory exception thing.
someone told me that they once renamed the scene completely different, and tried re-rendering batch and it worked…odd.
Maybe make a sacrifice and face west in the sixth hour of the equinox. Tempermental Mayan gods.

don’t know really for sure.


#3

I’ll try that. I have 2 gigs of RAM in this box. It shouldn’t be an issue… and it works when I render one frame.

Hmmm…


#4

Ok. That didn’t work. I also tried to export everything and then re-import. That didn’t work, either.

When I deleted the fluid in my scene, it batch rendered like a dream.

It has to do with the fluid.

Hmmm…


#5

Ok. I’m thinking I need to create the cache from frame 1 all the way to frame I want to start rendering at… which is 1849.

I made the cache starting at that frame before, and it seemed to work fine, but the batch wouldn’t.

I started a new scene, imported one of the default fluid examples, and noticed that I couldn’t do a batch with that starting on frame 1849 either. I did a batch render starting on frame 1 and it worked straight away.

What I’m doing now is baking the camera and scene so that I can make frame 1849 frame 1, render what I need from frame 1 on, and be done with it. I’ll also make the fluid cache from frame 1 this time.

Wish me luck, and I’ll let you know how I make out.


#6

I dont know what could be the issue Floyd, but be sure to post this over at Highend3d as well. The Main fluid guy posts there regularly.

Maya fluids… They have taken parts of my life that I want back. Best of luck…!


#7

Ok. I baked out the camera, and I’m caching the fluid now. from frame 1 to 552 instead of what I was trying to do before: 1849-2400

I moved all of the keys that went from 1849 - 2400 back to start on frame 1.

I think the hanging before was Maya trying to do the run up to frame 1849, only I didn’t get any errors (because there weren’t any) or warnings that it would take a long time to get the fluid up to where it needed to be.

That’s my current theory anyway.

I’ll know more once the caching is through.

Fingers crossed…


#8

IT WORKS NOW!! :buttrock:

It looks like the secret (I didn’t see this documented anywhere in the online help) is that the cache has to happen form frame 1, not just the frames you want rendered.

If you don’t cache it from 1, Maya tries to do the run up on the fluid sim during the batch render. Maybe there is an option somewhere to prevent this from happening?

Anyway, thanks everyone who tried to help. Sometimes talking it out and revisiting your work saves the day.

Edit: Just in case this tries to fry anyone else’s brain, I added this thread to the Maya FAQ.


#9

good man, thats one bug down…a ‘few’ more to go


#10

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.