Backburner: No plugin available to handle job


#1

I have been transitioning to MAX2010_64. Had previously done a quick test and network rendering seemed to be working but now that I actually feed a real project to the network
I have 3 slaves that are erroring out with the message ‘No plugin available to handle job’. All the other slaves are rendering fine using the same BB version.

                  I have read numerous threads on this issue but so far haven’t found the solution for me.  I uninstalled Backburner 2008.1.1 and deleted the BB folder and reinstalled but this error is still thrown.

I should note that in the Queue Monitor it shows the error: ‘No plugin available to handle job’ but when looking at the local Server dialog, it says: ‘No plugin to handle job: Autodesk 3ds Max 2010 (64-bit).

                                        Any other places to look to solve this?

Thanks for any ideas!


#2

It usually means that the registry values for Backburner is missing the path to the <3ds max root>
etwork*.task file. This is usually found in the registry HKLM\Software\Wow6432Node\Autodesk\backburner\ and verify that there is an entry pointing to the proper directory of the 64-bit 2010 .task file.

**WARNING: Modifing the registry can be very dangerous and shouldn’t be done without back up what you are changing or without knowing what you are doing. DO IT AT YOUR OWN RISK!

-Eric


#3

Eric,

Thanks very much for the ideas. In this case, I think it is operator error.

My main ‘Manager’ system runs Windows Server 2003 so it has the most connections and serves up the textures and receives the frames.

Originally when installing MAX2010_64 on all systems… Backburner 2008.1.1 was installed on this main server system but the new version of Backburner 2008 Manager throws an error (the Backburner 2007 ran fine on Windows 2003 Server but BB 2008 doesn’t). So I ran BB 2008 on all the other systems and re-installed 2007 on the Manager system. I must have missed a few slaves with the BB 2008 install and they were still running BB2007. That’s why they couldn’t run the MAX2010 exe for net-rendering… hence the error ‘No plugin available to handle job’… so the original error is solved.

That part was fixed by installing BB 2008 on those systems (except for the Manager system which has an error and I haven’t figured out what to do about that yet).

But now that the original error is gone… I have a new error on those systems that says: ‘Unknown error loading application’.

I examined the directories of the systems (where I just installed BB 2008) which don’t work and the systems which do work. It seems that there is no ‘Network’ subdirectory under the Backburner directory. Shouldn’t the install have made this?

I compared the registry keys for the area you mentioned and it appears identical on both the bad slaves and good slaves.

Thanks again!


#4

BB 2008 uses user directories like Max does, that may be why you aren’t seeing it.

-Eric


#5

Perhaps my question is to blunt… but have you installed max2010-64 bit on your slaves?
Even if 2009 and 2010 have the same backburner version (at least i think so), the corresponding max version has to be installed, beacause BB is only a pipe to 3dsmax****.exe?

Just to be sure!


#6

Thanks very much for the ideas.

Yes, MAX2010_64 is installed on all slaves. The first problem ‘No plugin available to handle job’ was solved by installing BB 2008 on those remaining slaves. Now they all can find/load MAX2010_64 successfully.

But now they throw the more traditional error ‘Unknown error loading application’.

So now I am on to trying to get a clean install of BB 2008/registry entries/paths, etc. I have found the post (at least I had it last night) where someone talks about editing the nrapi file, etc. Weird thing is, after doing an uninstall, delete BB directory, registry clean and a re-install of BB2008… it seems to install fine but does NOT create the Network subdirectory under the Backburner directory? Shouldn’t it?

I compared the nrapi file on the good slaves vs the bad slaves and it appears exactly the same… all entries basically point in the neighborhood of the C:/Program Files (x86)/Autodesk/Backburner directories. I don’t understand the post where it says to point them all to the MAX install directories as the good slaves all have them pointing towards the Backburner directories too.

Arrrggghhh. (Does Deadline have these types of problems too?).

Thanks!


#7

Oh and Eric, on the ‘user directories’ thought… all systems have MAX2010_64 installed at the root, all have their ‘UseUserProfiles=0’, etc. In other words, the good slaves and bad slaves are all installed the same way.

Thanks again.


#8

What I mean is that backburner data is now stored in “C:\Documents and Settings&lt;user>\Local Settings\Application Data\backburner” rather than “C:\Program Files (x86)\Autodesk\Backburner\Network”, and AFAIK can’t be changed. The useUserProfiles = 0 only effects Max, backburner is a seperate application and has nothing to do with that setting.

-Eric


#9

Thanks again for the ideas Eric. I’ve got to calm down cuz I’m losing network-rendering capability by the minute and starting to freak.

Let me see if I can start over with this.

Some of my identical systems are rendering a MAX2010_64 test project just fine and others are failing.

My first inclination is to simply uninstall/reinstall BB2008. But clearly it appears that old registry entries as well as a bunch of folders are left behind in this process. So some sort of manual cleaning must be done.

When I go to install BB2008… it defaults to C:Program Files (x86)\Autodesk\Backburner and I leave it alone.

When I compare systems after the reinstall and look at this directory, the good systems have a ‘Network’ folder below Backburner and the bad systems (with the fresh install) do not. Where is this folder supposed to come from?

On my most recent reattempt at reinstalling, not only did I delete the Program Files…Backburner directory but also those Backburner settings you mentioned down in Docs & Settings. After the re-install, the Backburner stuff is in Program Files… but there are no directories in Docs & Settings.

Anyway, still struggling to get a clean BB2008 install that works.

Thanks again.


#10

OK, some of the stuff appeared down in Local Settings after the first render was tried.

But compare the two attached images showing a good slave and a bad slave. Huge differences in directory structure.

Thanks!


#11

OK, on this issue… where 2 of the slaves will not participate in renders cuz they throw the ‘Unknown error loading application’ error…

I have tried the uninstall/reinstall of BB2008 several times and still get the error. I have compared good registry settings with bad registry settings (and made Bad the same as Good) and still get the error. I have copied folders from good installs to bad installs and still get the error.

I just tried the uninstall/reinstall routine again and searched through the registry for anything Backburner in the name. This time it did install all the proper directories into the Docs & Settings area (which is somewhat of an improvement) but when first starting the Server.exe app I get the attached image. You notice that it has NOT loaded the proper rendering plugin for either MAX2010_64 or MAX2008_32 (both of which are on the system) which tells me it did a lousy job of putting in the registry entries during install.

I added the entries by hand for MAX2010_64 and when starting the Server.exe app, it now shows the proper rendering plugins are loaded… but still gives the same error… sigh.

I’ll keep trying.


#12

Sorry… forgot the image.


#13

I tried doing a repair on the MAX2010_64 installation. Repair went fine… no joy. Error is still thrown when attempting to participate in net-render.

backburnerServer.log reports these specifics on the ‘Unknown error loading application’ error:

2009/07/23 06:10:02 INF Receiving new job from 192.168.1.20
2009/07/23 06:10:03 INF Job ‘test_render’ received and ready
2009/07/23 06:10:03 INF Launching ‘Autodesk 3ds Max 2010 (64-bit)’
2009/07/23 06:10:06 ERR Unknown error loading application
2009/07/23 06:10:12 ERR Error accepting connection: An operation was attempted on something that is not a socket. (0x2736).
2009/07/23 06:10:12 WRN Error 0x00002736 from main TCP server thread

Probably have to totally remove MAX2010_64 and try a total reinstall and see if that makes Backburner happy. Would be pretty absurd if I had to re-install the OS to make it happy.


#14

are all service packs and hotfixes insync? could it be a rogue plugin that’s misbehaving.

It helped me once when I in shear desperation copied all backburner related folders from a working slave to a non working slave and presto! (you’ll get duplicate server names but you can fix that later on)

You’ll get this error too when a slave hasnt got enough memory, so compare that to the working ones.

Have you tried yelling real hard at them? that sometimes works too! :slight_smile:

edit:

Can you browse the network to-and-from all computers?


#15

Thanks very much for the ideas.

Yelling… I’ve got that covered.

Each of the servers are identical dual quad-core, XP x64, 8GB, MAX2010_64, etc.

I just tried (awhile ago) stripping down the plugin.ini file on the bad slave to eliminate plugin issues… same error.

As far as service packs… whenever I install them, I install on the whole farm at once. In addition, since so many of these servers are physically identical and are used primarily for MAX/Combustion rendering only, I setup the MAX install with all folders, plugins, etc. on a single system and then use a syncing app to literally, copy the entire MAX folder structure onto all other slaves. So for example I have:

PC16 - XP x64, Setup MAX2010_64 here, copy to others
PC17
PC19
PC20 - Main Server (WinServer 2003)
PC21
PC22
PC23
PC24
PC25
PC26

I’ve already tried the copy folders trick but so far, it hasn’t triggered success. I will be continuing to try all these things until I get this solved but it seems like a registry setting problem to me.

As I mentioned previously… I originally installed MAX2010_64/BB2008 on all systems and installs went fine. When I first tried net-rendering the only issue was that the Main Server (PC20) was showing some weird messages in the Manager and Server when they were run (see this post here). (Because this system is WinServer 2003, it occasionally will have weirdness when you install stuff cuz it runs a bit different than XP x64). I tried for a while to solve these weird messages thinking they were some sort of error. In the end, I re-installed BB2007 on this system and ran the BB2007 Manager here. All other slaves running BB2008 Server connected to the BB2007 Manager no problem. So currently because of the BB2008 mystery messages on PC20… it runs BB2007 instead and all slaves are rendering fine to it.

So the other day, I go to actually start net-rendering a MAX2010_64 project across the network and I submitted a render job. As fate would have it, shortly after that I had a power problem where my rack was flipping the breaker. When it did this, all the UPS systems kicked in and supplied power. But I didn’t notice this condition for awhile and when I did, the UPS were almost drained. SO… I manually powered down PC16 and PC17 in the rack (to reduce the power load) and then turned the breaker back on. All other slaves continued rendering uninterupted . Guess which slaves I can’t make render now. PC16 and PC17. This could just be coincidence… but interesting.

Anyway… will keep trying but it sure would be nice if Autodesk didn’t have this stupid app spread all over the system and instead had a simple EXE to run like in the old days.

Oh well.

Thanks again for reading!


#16

Does your sync tool copy registry entries, too? If not that could be causing some of your problems. It is best to build a deployment and actually install on all machines, this ensure all files and registry entries are properly set.

-Eric


#17

Eric,

Thanks for the ideas.

The sync tool is strictly for copying folders/files… no registry stuff. But as you can see from the list, PC19, PC21, PC22, PC23, PC24, PC25 and PC26 were all copied in this same fashion and they are running fine.

Not sure what you mean by building a deployment. Is that some feature of MAX installs or do you mean Ghosting drives?

In any event, only two systems are having the problem so I’d like to avoid all the major re-installs if I can. Re-installing BB is not a problem but re-installing MAX is since I’ve got to also re-install plugins, etc. But I’m astounded that the installation routine for BB is so poor that sometimes it installs certain directories and other times it doesn’t. That it can’t even manage to get the MAX render plugins setup so that when you start Server.exe that it actually loads the MAX render plugins! I had to go and manually edit the registry just so it would show ‘Loading Autodesk 3ds Max 2010’ etc.

Anyway… I’m in the middle of a job so will have to experiment with this periodically until I solve it.

Thanks again.


#18

Network Deployment is an option on the 3ds Max install. It creates a install that can be run from the network and will do a proper install.

But I’m astounded that the installation routine for BB is so poor that sometimes it installs certain directories and other times it doesn’t.
It doesn’t, the folders you see in the backburner directory are from previous installs of backburner. Backburner 2008 uses user directories, the folders are just left over from a previous install/uninstall. If you uninstall backburner on all machines, deleted the programs folder and did a reinstall of 2008 you would see the same result.

-Eric


#19

Eric,

I have Backburner files/folders located at C:\Program Files (x86)\Autodesk\Backburner and Docs & Settings>user>Local Settings>App Data>backburner (per the images I attached earlier).

When I delete everything BB… and run the installer, the location it offers is the Program Files location. I just leave it at the default. The result is these folders in two locations. I don’t care where it puts them just so they work. The other working systems also have BB folders in two locations too.

Are you saying that your system has all BB stuff in a single location? I have already tried setting UseUserProfiles=1 to see if that would make some difference and it doesn’t. The installer installs in two locations.

(Anyway, my comment about directory installs was more directed to the fact that sometimes the BB installer will install certain sub-directories (such as ‘Network>others’) and other times it doesn’t. Maybe some of these directories are supposed to be created later when you launch BB the first time or something).

Thanks!


#20

the error number you seeing is an error generated from the windows tcp stack itself. (just google the number)

So I suspect its a system issue, not max. Try reinstalling your network card drivers, swapping network cables, change ip… fiddle around with those… see if it helps.

Maybe there are some pointers in the windows error logs. (right click mycomputer->manage-> see system logs)