Backburner and Maya on OS X - does it work at all?


#1

I have spent the past couple of days trying to figure out how to get Backburner running on OS X in conjunction with Maya. But in spite of all the difficulties I already managed to solve it still won’t do as I command. So I don’t know if it’s just me or the software and it would be very interesting to hear if other people encountered the same or similar problems as I do.

So here is a wrap-up of what happened so far:

  • after installing I tried to find the backburner application which appears nowhere on the system
  • the manual didn’t help and is imho one of the worst written manuals I have ever seen; full with information but missing the most important ones, like how to start backburner and get it running
  • the manual talks about:

Once completed, verify that the needed components have been properly installed and started. Go to Applications / Autodesk in Finder, and open the Autodesk Systems Monitor application.

There is not such a directory or file!!!

  • after digging through the entire manual I find the important information how to start the web monitor from the browser and how to log in! Ok, - that works at least

  • I also went through the entire process that is described to make sure the manager is running and how to setup a user before figuring out that it is not completely necessary, - so well!

  • open Maya to get a scene send to Backburner but

(from Maya Docs) When you select Render > Create Backburner Job, (
)

doesn’t exist!!!

  • ok, after digging some more I figure out the script this command should pull up (performExportToBackburner.mel); having some experience in MEL scripting it is not complicated to get that one running! Fine!
  • my server is running and appears in the web monitor, manager is up too; all is well
  • but when hitting “Submit Job” in the Backburner for Maya window nothing happens, even though the script editor tells me that the command was submitted to Backburner! But there appears nothing in the Backburner Monitor!
  • After even more digging and ripping apart the script I figure out the command that gets sent to Backburner and which is created by the MEL script

system (""/usr/discreet/backburner/cmdjob" -jobName “rendertest1_191714-100118” -jobNameAdjust -description “” -manager ingoMBP.local -priority 50 -taskList “/var/folders/…/rendertest1_191714-100118.txt” -taskName 1 -delete “/Applications/Autodesk/maya2010/Maya.app/Contents/bin/Render” -r file -s %tp2 -e %tp3 -proj “/Volumes/DataHD/_projects/dom” -rd “/Volumes/DataHD/_projects/dom/images” “/Users/ingo/Documents/maya/projects/default/scenes/rendertest1.mb”")

  • ok, it’s a system command, that puts the contained string to the shell and execute it! Well, I can do it by hand - but no matter how I format it with or without the starting and end quotes it gives me an error

  • the command only works if I eliminate ALL quotes in the string, like

    /usr/discreet/backburner/cmdjob -jobName rendertest1_185307-100117 -jobNameAdjust -description “” -manager ingoMBP.local -priority 50 -taskList /var/folders/8M/8MLUdjUQGMasNlpTYfdF5E+++TI/-Tmp-/rendertest1_185307-100117.txt -taskName 1 -delete /Applications/Autodesk/maya2010/Maya.app/Contents/bin/Render -r file -s %tp2 -e %tp3 -proj /Users/ingo/Documents/maya/projects/default -rd /Users/ingo/Documents/maya/projects/default/images /Users/ingo/Documents/maya/projects/default/scenes/rendertest1.mb

  • but now the cmdjob complains about “-jobNameAdjust” and “-delete” which is not recognized and gives an error - well that is strange, isn’t it?

  • after deleting the wrong statements, cmdjob tells me that the job is sent and created some tasks - it now FINALLY the job also appears in the web monitor. Wonderful!!! - BUT

  • the job gives me an error in the web monitor:

Cmdjob adapter: Strip brace failed.

I have no clue what that is supposed to tell me! And this is where I am stuck now.
So if you read this and have only the slightest idea what to do, what this error means and how it could be solved - please tell me. I am desperate.

As a last note: I find it very strange that a tool that is around autodesk for years now (I have used it in the past for 3ds max) is so difficult to handle, so akward in its use and (at least for me) so poorly ported to OS X. As I mentioned before, I don’t know if it’s just me - I only want to understand.

Thanks for listening! Cheers, Ingo


#2

I’m assuming it needs to be tweaked for the OS X 2011 version to work. Hopefully that won’t be very long. The docs for Backburner clearly mention Smoke and Maya 2011 - so I think the broken script was included by accident with 2010.

Otherwise, grab Frantic Deadline if you need a queue manager for OS X or just use batch scripts.


#3

I guess so too. Just too funny that it’s an official release supposed to work with maya (that’s at least what the download said) and I also have found a post on the area where someone got it to work (at least what he said). But I haven’t got a reply from him yet. So I am in doubt that it works at all. Which leads to the question if Autodesk has tested it at all before releasing it… so much guesswork… Well maybe it’s time to stick to the methods that work… I also filed a report to Autodesk but no replies so far either…


#4

Well it looks like they added official support for Maya 2010 judging from the updated docs. I’ve managed to get BB installed and a user added and got the web admin working (these docs are piss though). I tried manually adding a job from the Terminal but it didn’t work - I need to read over the cmdjob arguments and then backtrack to see what the submission script is doing something wrong from within Maya.


#5

ok - so I think I found the culprit of the Terminal submission failures. In the backburnerServer.log file (in /usr/discreet/backburner/Network/ ), I found this. It fails because it can’t find Maya even though that is right path. This means I going to add an environment variable to point to it and see if it works.


2010/01/18 22:11:44 INF Application is down
2010/01/18 22:12:15 INF Receiving new job from 10.0.1.7
2010/01/18 22:12:16 INF Job 'handjob' received and ready
2010/01/18 22:12:16 INF Launching 'Command Line Tool'
2010/01/18 22:12:16 INF New task assigned: 1
2010/01/18 22:12:16 INF [ServerMessage]ProcessStarted processId=1859
2010/01/18 22:12:16 INF #??#
2010/01/18 22:12:16 INF Starting "/Applications/Autodesk/maya2010/Maya.app/Contents/bin/maya"
2010/01/18 22:12:16 INF Error: could not find installed copy of Maya.  Please install maya
2010/01/18 22:12:16 INF or set MAYA_LOCATION environment variable to point to location
2010/01/18 22:12:16 INF // Maya exited with status 1
2010/01/18 22:12:16 ERR Task error: Cmdjob adapter: Process exit abnormally,Exit code is 1

2010/01/18 22:12:16 ERR Cmdjob adapter: Process exit abnormally,Exit code is 1

2010/01/18 22:12:16 INF Application is down


#6

I can’t get it to stop tripping on this error. I’ve set the environment variable but it refuses to work. I’m asking Shawn at Autodesk to see if he can confirm that this actually works with 2010. Considering this and the state of the submission script failures, I really doubt it does.


#9

@cgbeige:

thanks for you input. I figured out the backburnerServer.log file too but it gives me different errors, depending on how I tweak the command that’s sent to BB. I came across the one that it looks for the maya app also (exit code 1) as well as a different one (I don’t remember). But I found that the “strip base failed” error must be pretty close cracking the nut. But I am not sure. It would be great to have a help line to the cmdjob just like with the render command in terminal. But I guess that doesn’t exist.[i][b]

@[/b][/i]BoostAbuse:

Hey Shawn, I hope you get well soon. Also thanks for dropping into the subject and your help so far. I actually have already tried to contact the support on this one but nothing so far unfortunately.

Like I mentioned before I really wonder if they ever tested BB on OS X. Wouldn’t it have been obvious that it doesn’t work? I mean i am not a programmer but working my way through with mel and some objective C and I always test things as much as possible to make sure everything is alright… my 2¢


#10

Maybe it works for the Smoke people but somebody – I’m talking to you Cory Mogk – in the Maya camp jumped the gun :wink:


#11

pretty sloppy. Glad I wasted three hours on this (this is my second attempt to get this working). I’m going to walk my dog down to Old Montreal and have him piss on Discreet’s building :stuck_out_tongue:


#12

Careful…if you lived in the US that would be construed as “making a terroristic threat”. :wink:


#13

hah - ya. well we’ve had a rash of mafia-style molotov cocktail bombings here so I can just say I’m fireproofing Discreet’s office.


#15

if it’s any help, the docs say that the user should install the Backburner Maya components from the Maya installer but there are none in the installer options. I think they changed the docs to read “Maya 2010” when they realized that it said “Maya 2011” and then changed it for the sake of changing it, not realizing it would cost people a lot of time.


#16

just a heads up that messing with your environment variables will bork Maya:

http://forums.cgsociety.org/showthread.php?f=7&t=844613


#17

hey guys, thanks a lot for your time and input. I really appreciate it. Although I am still stuck with the same problem at least I know that it’s not me and I don’t feel as stupid anymore. If I find out more I will let you know… So thanks and farewell, take care :slight_smile:

Cheers, Ingo


#19

Has anyone downloaded the Smoke trial? I wonder if it includes the BB GUI apps pictured in the docs that let you manage the Server and Manager?

I already have a working BB farm going on a stack of Windows machines and after installing BB on the Mac I was bit confused as to how to point it towards an existing Manager. Or is it even possible to have a mixed environment like that.


#20

Shawn - can you try and get it working on your side? I’m kind of fed up at this point and don’t want to bother since I’ve wasted enough time on this, especially since changing the environment variables cost me a day of down time yesterday.

I don’t think it’s too much to ask that someone at Autodesk can confirm that this actually works.