Arnold AOV's with no alpha


#1

I don’t understand why some AOV’s render without alpha and some do. My Ambient Occlusion AOV (custom) always renders with no alpha. That is, maybe it has alpha but the whole image is opaque even if the beauty has tranparent areas.

I suspect it has to do with skydome light, that this somehow “occupies space” and thus shows up in alpha as white pixels. If this is the case, how can I stop it from happening? I have turned off camera visibility in the light’s shape node but how can I turn it off for a specific AOV?

Thanks


#2

2 months and no reply… :-\

But yes, you’re right, the Skydome is picking up the AO as well. Turn all lights off and re-render the AOV, and all is still there with an alpha if applicable.

I ran into your post as I want to know the exact thing. How to turn off certain lights for a AOV, instead of having to build another renderlayer for the AO to get alpha.

Hope this will bump it up for an answer…

Edit: After thinking about it, it might make the most sense to just extract the alpha from the beauty, and copy that back into the AO. In Nuke that would be a CopyChannel, in Fusion a Channelboolean.
Takes less work than trying to do it in Maya’s renderlayer setup.

cheers!

rob


#4

most renderers don’t waste rendertime rendering another duplicate alpha - but daniel’s full-frame solid alpha sounds more like a bug