Arnold 5 - Mesh Light Problem


I’ve searched the forum to no avail. Here is my problem :

I was modeling a room inside which I have made a logo on a wall.
Around that logo, I wanted to create a Torus mesh light using “Arnold -> Lights -> Mesh light”.

The operation didn’t work properly at first, as I though Arnold would maintain my mesh roundness (from view “3”).
So I copied my mesh, gave it a “Smooth” operation of 1 division which made it more round.
I then reapplied the Arnold mesh light.

The logo was down too much, so I selected the entire logo (with the torus), and brought it up a bit.
After a render, this is what I’m getting :

A black circle will constantly appear at the same spot, whatever I do.
I have tried to delete any “Mesh light” thing in my outliner so I can start anew, even copying and deleting my torus.
Nothing works. I can’t get rid of that black circle.

I have also looked into the hypershade under the “lights” tab. There’s no object to be found that are related to that “mesh light” operation.

Can anyone tell me how can I find this black circle and delete it?

Also,… since that may have caused the bug :

Can somebody tell me how to move such a light ?
I think I had an error message from maya that told me something like : “Warning: Light instancing or re-parenting is not supported by Viewport 2.0 //”

When we want to reposition an Arnold Mesh light, do we have to move the mesh AND the light (that are found in the outliner), or can we move the mesh only just fine?

I really hope somebody can help me with that black circle, because now, it’s really stuck in my scene.
Thank you!


Hello again,…

I have temporarely resolved my problem (I think) by deleting completely the last Torus that was used to create these lights.

I really don’t understand this behavior though, as that last mesh had no “mesh light” attributes attached to it, nor was any “mesh light” related shape could be found in the outliner.

These black circles were just there,… without any way to delete them, except from deleting the 3rd copy of the original mesh?

So my question is still opened : how can we delete a Mesh light without (or those residues of blackness) without deleting the Mesh itself?
Just for the record : my mesh was registered as “polymesh” under the “Arnold Translator” tab of its shape. Not as “mesh_light”.

It’s really difficult for me to grasp how Arnold handles its “Mesh light” attributes,… I know they’ll be found under the “defaultLightSet” of the outliner, but not in the HyperShade.

Any shed of light over this matter will help me a lot.
Thank you,


Did you read the manual pages for meshlights: MeshLights? There you can read that smoothed geometry and nurbs do not work with meshlights. Maybe you have to increase the brightness of your meshlight to make it more visible.

In my case (Maya2018), the meshlight node appears in the lights tab in the material browser, so I can delete it if needed. If you do not see it, you can simply select it in the AttributeEditor. Go to the tab which shows the mesh light, select it and delete the node.

And in my case, I can clearly see the light shape below to my geometry in the outliner.


Hello Haggi,
Thanks for replying so quickly !!!

Yes, I had read that a nurbs or smoothed mesh can’t work (for the moment : Arnold 2.0.1).
But the smoothing was a mesh based smooth, which after deleting the history, was gone, leaving the mesh “as is”. So I don’t think that was the problem.

You’re lucky to find it in the “light Tab” of the hypershade,… in my case, I couldn’t find it.
And for going into the attribute editor,… well,… that was also the problem, since no lights at all seemed to be attached to the mesh ; when selecting the mesh, there was no light attribute to be found.

I have another small issue (which I wonder if I should repost somewhere else,…)

Now, when I try to add any type of lights, I can’t use the “Use Color Temperature” option from the attribute editor.
I can tick the checkbox,… but the “Temperature” slider under it is not accessible (greyed-out).

Like I said,… my issue with that “black circle” is sort of resolved,… by deleting the entire torus (that wasn’t a light, but still linked to the black-bug).
Now I can’t use the “Color temperature” option anymore,…. this is very strange,…
Any help would be appreciated.
Thanks !


Okay, MtoA 2.0.1 is a bit older but should work the same way. Which Maya version do you use?
You have 2 ways to create a mesh light.

  • Select a mesh and apply the Arnold->Lights->MeshLight menu
  • Swicht the translator in the mesh shape to “mesh_light”

The first way creates a new node and connects it to the geometry and the new node should be visible in the “Lights” tab in the Hypershade (at least in Maya2015) and in the Outliner as well was in the AttributeEditor. The second way does not create a new node and is not visible in any editor because it is only an attribute on the mesh and you set all settings there. Mabe the second way is the easier one because you do not have to work with an extra node.

So you should restart again and use only the mesh light option on the mesh.


Ok ! Thank you very much for the info Haggi.

I’m using Maya 2018 (MtoA 2.0.1 / Arnold Core

I’ve read somewhere that using “Emission” was a really bad idea, as it would produce way more noise than a mesh light.
You can see in my last image that I’m using “Emission” on certain faces of my mesh.

Should I really make a mesh_light out of the extracted faces of my geometry ?
“Glow” doesn’t seem to be an available option anymore,…

Again, thank you so much ! :slight_smile:


I’m not sure why you are now talking about emission if you want to use a mesh light.
Indeed, using emission as a lightsource is not a good idea. Just change the translator of your geometry to mesh_light, that’s all. Glow should be done in a compositing program.


Ok. Thanks.
I was asking because the circle around my logo had to be a mesh light. (As a neon light).
The logo itself (as I wanted only some part of it to glow*), had to be emission, since I couldn’t find the “glow” attribute anywhere.

I’m not sure yet what I should do to obtain the effect I want… that “glow” attribute was fun to play with,… to have just some faces to illuminate, without beeing the principal light source.

All in all, this sure have shed some lights on the subjet. :smiley:
Thank you so much Haggi !
have a nice day !