Animated distribution map problem


Hi guys,

I need to use an animated map to distribute the particles over a surface. Here’s a pic of what I have so far:

I need to make particles disappear slowly (to simulate deforestation on the globe), so I was trying to use an animated map to do this, but they do not disappear. I set the Density by Material in the Position Object node to use the animated map, but nothing happens.

I made a little search, and someone wrote that you need to have a Speed by Surface node set to Speed by Material / Grayscale Multiplier for the effect to work, but it does not work for me either.

Any suggestion to fix this, or maybe another efficient way to accomplish this effect?


The Speed by Surface set to ‘by Material’ is the way to go.

I would create an inverted version of the birth map (you can do that directly within max with an Output Map or the Output rollout of the Bitmap Map) for the speed and then use a Speed Test to send the particles to a Delete event.

If you want the trees to shrink before deletion, you can use an animated Scale Operator and an Age Test. Just wire the output of the Speed Test to the Scale event and the output of the Age Test to the Delete event.


Hey Piflik,

thanks for your quick reply. I just tried what you said, but I see nothing new.

Here are my nodes and relative settings:

I must be missing something; the particles do not do anything at all. The map in the Object Position node is used to put the particles on the surface of the object. The same map is in the Speed by Surface node (obviously the map is animated). The Birth parameters are as follows:

Emit Start: 0
Emit Stop: 0

…because I need them to stay on the surface all the time, from the beginning, and just disappear when I need them to.


You don’t have any object in the Speed by surface event. You have to put your emitter (or another object) in there.

It would be easiest to copy the emitter object and apply an inverted version of the emitter map on it and use this as the speed control object.


yes, you’re right. But I put the object in the Speed by Surface, and still nothing happens.

I tried with a simple scene…a plane with an animated noise texture; it’s all white in the start (so all the particles should be drawn), and then it becomes darker in some areas, till it becomes black. But the particles still stay the same, all over the object…


I just tried it, and I don’t have any problems…

I just noticed the value in the Speed Test. You should lower the test threshold in the Speed Test. The particles’ speed is multiplied with the grayscale value (not 0 to 255, but 0 to 1), so no particle will ever be faster than the 3.0m you specified and thus not deleted.


Great, that was the problem. Thank you very much for your help.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.