Alembic from C4D to Maya - Not working


#1

Hi,

Let’s keep it simple. I have a much more complicated project that’s being rendered in vray on maya (also making a trip into Houdini along the way) and the alembic export from Cinema is just wrong. It’s making me look bad in front of my Maya and Houdini friends here at the studio.

Simple test we’ve done:

I am animating a cube. 0 degrees to 720 degrees on x(h). Linear. I export that as an alembic. it looks fine in Maya and in Houdini. However when rendered in Maya the motion blur goes all whacky because in the subframes the cube is rotating on other axis. No matter how many subframes I export, or how little I uses, or even when I use none. When you scrub the subframes in Houdini you can see the cube jumping all over the place.

There is something wrong with the alembic itself out of C4d? Is there a solve for this? It’s like a gimble lock Euler problem but there’s no way to fix it. I need to solve this as I am the animator and it’s really my problem.

Thanks for any help!
-rand.


#2

By default Cinema uses HPB rotation order… change it to stick with MAYA default, which is XYZ …
Also for Motion Blur you can put more subframes in Alembic export…


#3

How would I go about doing that?


#4

At the Coordinates Tab of each object on the bottom Right you can change rotation Order.


#5

In Cinema … Selected Object/ Attribute Editor / Coordinates(Coord.), under Rotation Fields you have Order List, to set Rotation Order…pick the XYZ and go on…:slight_smile:
Make sure in Maya, you are using the same order XYZ …


#6

In attributes manager under coordinates is a button to change it. Alembic even in C4D does not render MB properly with default settings (you need to bake a polygon copy of the alembic object via timeline baker).

From the help it states that the object inside of C4D is not holding the animation data but the base alembic file stored on your hard drive outside of C4D is having it. So there are no actual animation info available to the C4D’s renderer it seems. Strange…
Maybe for Maya it’s the same or maybe you have to export a .fbx/.obj with the .abc file which is linked to the .abc file? But I don’t know if that is possible. Or relink the .fbx mesh data in Maya with tthe .abc file if possible?

https://help.maxon.net/us/#50804

cheers


#7

Thanks for the tips guys, but this does not solve the issue. My cube that is rotating around (now on Y instead of H) still comes into Houdini and Maya with subframe issues of random rotation in the subframes causing wonky motion blur.

Any other thoughts as to why this would happen?


#8

My suggestion is to remake animation AFTER the order is changed… Here It’s working, stride forward …
Attached abc file, exported from Cinema …


#9

You are correct. That is working. HOWEVER: Try putting that into a null and doing your animation on the Null then opening it with Houdini or Maya. That’s the problem we are having. If we animate directly on the objects then it’s fine. But as soon as we have a null tree we run into the problem. Appreciate the effort by the way!


#10

Sorry, but I can’t confirm your issue . I have exactly the same correct result with Null. Hm…Did you change the order for the Null ?.. I guess you did …


#11

Yep I definitely did. Are you using r17.048?

Are you testing the clip in Houdini or Maya by chance?


#12

Just to add my two cents, I tested the scenario you described using R17 along with Maya and Houdini. So far, I’m not able to reproduce the issue you’re having, as motion blur seems to be working correctly. I’m not doing anything special, but in trying to follow your example I created a cube, parented it to a null, added a rotation on H, and exported as an Alembic with subframes set to 4. I’ve tested in Mantra and Arnold and everything seems to be fine. I don’t have Vray, so unless the issue is specific to it?

From past experience, however, I can attest that sometimes object hierarchy can screw up how other programs interpret the rotation order. If, for example, you have a lot of nested, or parented objects, that are all keyframed, there may be an issue with precedence (they’re all fighting over who rotates first).

To test this theory, take your object and instead of animating it with transforms, try binding it to a single joint and animating it that way. I know that sounds strange, but that’s the only way I know to confirm whether the issue is with your scene hierarchy. If it works, then the problem is in how your objects are setup. If it still doesn’t work, then it’s more than likely a bug or some other limitation.


#13

Yes, R17.048 … imported in Maya 2016 and batch rendered with motion blur with 2D type … MAC by the way …
Hope you find solution … :frowning:


#14

Hmmmmm weird. Will try again tomorrow. Thanks for the help. I will post if I find out what’s what.


#15

I’ve attached the file I animated in C4D. It’s a cube spinning around. See if it works. Houdini and Maya are having subframe problems.


#16

Hey Ugrens,

I actually brought your alembic into Houdini. It has the same sub frame issues. Null or no null the issue remains with alembic files from C4D.


#17

You can see that there’s some gimbal flips on the animation even looking at whole frames of the cache in Maya, for a few frames the X and Z rotations flip 180. I’m not sure if those are in the source file or not since you didn’t include that.

I believe that C4D’s Alembic implementation doesn’t support subframes at all, I’ve seen a few threads here on motion blur issues as a side effect of this (do a search in this forum and you should find them).

I guess one thing you could do (apart from letting Maxon know that they need to fix Alembic so that it handles subframes!) is bake the animation down to regular keyframes in Maya and then run the Euler filter on the keys, in your simple example here that fixes it, but of course I don’t know if it will work for a more complex hierarchical animation.

Generally with any jobs I’ve done between C4D and Maya I’ve always been bringing animation from Maya to C4D rather than the other way around so I don’t have any more ideas for now.


#18

I can confirm this issue, at least going from C4D to Houdini via Alembic. It seems to get stuck on the same frame every time, although if I use linear keys it doesn’t seem to appear. I’m just trying the same setup you described, with a spinning cube. I’m not sure it’s related to rotation order, but maybe just a limitation of the Alembic exporter. I’ll try a few more things, but the moment it sounds like you’re going to need a creative work-around.


#19

Just for my own sanity. What is the Shutter Speed or Shutter Angle you are rendering at?

We were at 0.5 in Maya. We have changed to 0.4 and the issues on our test have resolved themselves. We are now doing a larger test with our original animations.


#20

In Arnold I’m using the default, 180 deg with a length of 0.5. Mantra is also the default, with no offset. I tried changing these values as you suggested, and it actually makes the problem worse on your sample file.

So it seems I’m not able to successfully reproduce this issue by recreating the scene as you describe, but the Alembic you provided (v03) does render incorrectly for me (on frame 13). Could you possibly post the C4D file you used to create it? I’m curious about any other scene settings in there; framerate, unit size, etc.