Afterburn


#1113

Ups double post


#1114

My torments with afteburn :wip:
http://www.youtube.com/watch?v=mnBxCKcjvNk


#1115

I’m having this problem with Afterburn Combustion where it refuses to make geometry cast a shadow.

This is the setup: Afterburn Combustion volumetric cloud, Direct Light pointing into the cloud. Geometry in the beam of light.

The problem is that the geometry does not generate a shadow, the lights DOES illuminate the geometry and at the same time passes right through it…

Here is a picture of it: http://www.guthmangroup.com/img/3D/noshadow.png (also in attachment)

Renderer: V-Ray 1.5 (but the same thing happens in scanline (which takes like 10x the time to render the same thing!)
I’ve tried every shadow type available for the lights, all result in the same…
Using other types of lighting aren’t suitable as I need a directional beam, not a spot-type.

Enabling “Compute Advanced Lighting” and “Optimized atmospheric evaluation” didn’t do anything.

I’ve inserted a sphere into the scene make the problem easy to spot.

This is the light setup: http://www.guthmangroup.com/img/3D/lightsetup.png (also in attachment).

Anyone have any clue how I can fix this?


#1116

Uploaded with ImageShack.us

I’m trying to make a meteor effect but having problems with rendering. If you can give me some tips to make this render better, you’d save my life. I’m explicitly concerned with the weird smoothness and the lines that go around the smoke.

I have one spot light on the scene with shadow map. I’m using Afterburn 4.


#1117

Your Step size in the render panel looks rather large, this would be the cause of the artifacts (the smooth lines), try lowering you step size, this will increase render time, but give a nicer result :slight_smile:


#1118

Maybe make sure your lights have “effect atmospherics” checked on?


#1119

That fixed it! Thank you, saved my life.


#1120

hi,
i have a question, maybe this one somebody already asking before… sorry if repost…

how to set/get afterburn more opacity/less density, if they near/infront camera?
case:
i have thin smoke along the tunnel using pflow with afterburn…, and i have animated camera thru the tunnel, the problem when camera thru the smoke some like blank white covering camera… if we view rendering like flicker…
so maybe will help if i can set density gradually become lesser if they near camera.

btw anybody have try ‘geometry clipping’ in afterburn rendering setting? how to make this work, i tried 2-sided material too, but didnt work…

thks.
prie


#1121

Do you have Thinking Particles? If so, I can post a scene later showing how to archieve that effect.

Cheers
Nahuel


#1122

so actually its particles side setting? not afterburn setting? can be done with pflow?
can say yes, i have TP.( still learning TP, sometime still thinking like pflow (events base) when using TP (rules base)… hehehehe)

thks

prie.
http://vimeo.com/prihardimansyah


#1123

Here is the scene.
So, basically I create some particles inside the Tube. Then in a new Dynamic Set, I do the fade operation, and save that to a data channel (CH0 - Density)
In AfterBurn, you can use that channel in the Sphere Radius (just for visualization, you can adjust the Near & Far values in TP). After you like the fading, you can load it in the Density (setting Low Value to 0, and High Value to 0.5 -for example-). That’s it :slight_smile:

Here are some images (remember to add the geometry -in this case tube- into the Node op of the VolumePos, and also add the Camera into the FadeByCamera Dynamic Set)

http://img847.imageshack.us/img847/9887/ab00r.jpg
http://img687.imageshack.us/img687/4431/ab01o.jpg
http://img94.imageshack.us/img94/3252/ab02s.jpg

Cheers
Nahuel


#1124

thank you very much…Nahuel


#1125

Hi !

Being in my last year in a 3D animation school I have to make a short film about a plane sculpting a woman’s head into clouds.
So I intend to make the clouds with Afterburn but I need to have a precise shape with detail … I have the head’s mesh fill up with ParticleFlow on surface but the thing is : in Afterburn I would like to have different sphere size depending on the detail of the mesh. (I need smaller spheres around the eyes, nose, mouth and ears). I tried to animate the sphere size on object distance mode with another mesh -which was just the eyes, nose, mouth and ears areas- but the object distance mode seems to work just with the pivot point and not the shape of the object itself …

Does anyone already did it ? Any idea ?
It could also be great in PFlow to have more particles in detailed areas and less in others ! I don’t know how to do that…

To fill the head I need a lot of particles : around 400,000 ! Is it still a good way to work or should I use a completely different method to fill up a shape with AB ?
Or perhaps I can make this kind of cloud with something else than Afterburn ? Another plugin ?

Thanks a lot for any answer !


#1126

Raphtillie, i think you have several options:

  1. use Thinking particles (cebas Visual Technology Inc).
    make base head mesh. apply grayscale texture and use this texture to spawn different quantities of particles on the mesh. Create Float channel for this particle group. store size of future afterburn puff per particle and then use it in afterburn via TP Float IC.

  2. or you can use pflow (weird way)).
    As far as i know afterburn can’t use all these user channels (particleVector, matrix etc). all you have access to are pAge, pVelocity, distances and expression.
    i’d use particle age to store the size of corresponding afterburn puff (through script operator. And don’t forget to set finite age to particles with Delete operator for example) drawback - you will not be able to use age based test and operators (or store age in user channel).
    here is example (age used as size):

  3. some better way=)


#1127

Hi,

Thanks a lot for those ideas ! My school doesn’t have any license for Thinking particles … I don’t think they would buy one. So i’m trying the 2nd method !
I’ll post some news when i’ll manage it !

Thanks again !


#1128

Hi all, I’m a hobbyist, and I’ve been trying to learn Afterburn following some online tutorials I’ve found. I’m using 3ds Max with vray 2, and AB4.0. I set up a simple scene with a PF Source, and a standard spot light with shadows turned on (I’ve tried all shadow types). I also turn on atmospheric shadows. I delete the rotation and shapes elements in particle view, and add an ABPflow element. I add the abpflow and light to AB and leave everything at default. If I render the scene without self shadows on, it renders (but no shadows). If I turn on self shadows, almost everytime, Max crashes to desktop. Sometimes Vray posts an error “…render region xxx…”, but the dialog says that although Vray generated the message, it may not be responsible for the error.

My system is dual opteron 6170s on an Asus Kgpe-D16 board, 24g ram, Quadro 2000, an intel 120g ssd for my OS, a hybrid drive where my programs live, and a couple other drives for storage. Oh, and win7 ultimate 64 bit.

I certainly will appreciate if anyone can help me solve this problem.


#1129

So… we just updated all our stuff to max 2012. We have new installers and lic info for both fume and ab. The lic info is all good. Fume will sim and render. Afterburn however I can get into the plugin just fine fiddle with settings and so forth. However It will not render… it renders to straight black. I have no idea why. Old files from max 2010 don’t render even the sample scenes just render to black. Anyone have any ideas? Could it be a DCPFLICS issue? I know the new stuff uses AfterFlics. Both are on my work machine.


#1130

are you using the new afterflics license server?


#1131

Ya we have all that figured out now… Thanks.


#1132

AfterBurn 4.1 was released a few days ago which fixes the problem and adds a Max2013 installer! I have to admit that new release totally flew under my radar until yesterday. Updated immediately. You might get an “AfterBurn Glow” loading error for duplicate IDs if you had former AfterBurn builds installed. Just remove the old Afterburn.flt file to fix this.

-Anselm