Advanced Skeleton - corrective shape issues


Hi All

I have only been learning 3d as a hobby for a year or two now, and have put off learning rigging because i knew it would be tedious. I finally jumped into it recently and know the bare basics of it, but got hold of Advanced Skeleton to help. At first i was very happy with it, but now i am running into problems.

I have a working rig, but i am trying to use the corrective shape functions in Advanced Skeleton to make my joint deformations better. The problem is, it doesnt seem to be working like it is supposed to. I click the create corrective shape button after rotating the joint in question, sculpt the mesh to make it look more realistic and then click apply. After clicking apply, all seems well while it runs through the calculation to apply the blend shape but after it has finished, the joint loses the definition i just sculpted and goes about halfway back to its original state. It is doing something, because if i find the blendshape in the shape editor or in the inputs in the channel box and play with the controls there, i can see it is doing something, but not what i sculpted.

I figured this has something to do with deformation order, and i did manage to confirm that (i think) by sending the blend shape to the top of the deformation order and then finding the blend shape in the shape editor, enabling edit mode there, and re-sculpting the joint. After that it seems to hold my sculpt, but does not mirror to the other side of the model like it would if it worked through Advanced Skeletons function.

I have watched quite a few videos on Advanced Skeleton, and have not seen the problem i am having, nor any axplanation of something to do to prevent it. In the videos it just works, the sculpt is perfectly kept.

So i am hoping someone can shed some light on why it doesnt seem to work properly for me. I am pretty sure i did everything in order building the skeleton and rig through the plugin, and cant think of anything that would cause the issue im having

Any help would be much appreciated


Same problem, does anyone know how to solve it?


well I have the same problem, especially when I’m working on characters and on conflicting areas like biceps. I haven’t found a direct solution in the Tool but I manually used graph editor and tried to drive joints and blend shapes values manually agian. I hope it helps.


I also captured this picture that if you look at the yellow message it refers to that this action happens consciously


it says the rotation is changed to 90 degrees but I’ve moved it 95 degrees.