3ds max does not premultiply passes


Hello dear colleagues!
Whenever I save whatever images, checking premultiply or not (TGA, EXR), they still show the color of the background unchanged, whereas it should be black, if premultiplied. The backgdound is just the environment color with alpha transparency 100%., and the teapot is opaque. What could be the issue?


İf you are using 3ds max to view the output, It might not be dislpaying the alpha channel. In that case try to use another viewer.


Thank you for the reply!
It doesn’t affect the result. I viewed it in fusion and photoshop, the result is still the same.


Can you send another example in, I can not download one you attached here.
Meanwhile try .png with alpha channel as output, and inform me about the outcome.


This sounds like you don’t have alpha enabled in your output options. TGA needs to be set to 32bpp to output the alpha. EXR needs RGBA in the drop down. PS always treated alpha in TGA as alpha and not transparency (like it does with PNG) so it won’t auto-magically knock out the BG from TGA.


First and foremost, thank you for your replies!
I tried to save it in 3 different formats, also saved it from Vray buffer to check if it’s a scanline issue.
It still saves the background color (“8” shortcut menu). All renders are identical. 3ds max does not premultiply by its aplha the background color in the output, even if the option is premultiply.
It seems it preumes the background color should be black, otherwise it renders it colored and not premultiplied. And if making it black, it’s the same as if it would be premultiplied.
Perhaps most people just render on a black background.
You can easily check it, just make background color any other than black and save it.


This isn’t a bug or unexpected behavior. You don’t want an alpha channel or you don’t want an alpha to behave as an alpha by default. What you’ve described is using an alpha as an RGB multiply to turn your background black instead of masking it out as designed. Also why do you expect it to work your way? Max treats the background as transparent. See the manual


Correct. This might be the cause.

From BOC Sciences


Max does not change the background colour to black when you premultiply. It takes into account the background colour on pixels that contain alpha. That way in your Compositing package you are able to take into account the background colour and then remove the background colour value from the Alpha.

Fusion ‘expects’ images with Alpha to be supplied with Black as a background and it doesn’t give you the option to change the background color on Impot (or this is true of the older version I used to use).

You need to do this manually in Fusion. Google it…

The other way around this is to use an environment/background switcher in Max.Most renderers have this.