2018 bug with export Alembic


#1

Hello everyone,
i have a weird bug exporting animation with abc file
in 2017 all work fine, the .abc cache export facial animation (blendshape) and animation(skincluster).
if I open the same file in 2018 and try to do the same export, the .abc file export only animation by skincluster, the blendshape will be ignored… don’t understand why…
the character’s structure is:
2 meshes:
mesh_A: only blendshape
mesh_B: mesh skinned with an input blendshape node from mesh_A

anyone have an idea why 2017 works better than 2018?? :smiley: :smiley:
thanks guys


#2

Hi Kimus,

This indeed does not work in Maya 2018, very frustrating when your pipeline heavily relies on creating blendShapes between alembic caches and modeling assets…so far the only solution I have found was sticking to Maya 2017 for abc caching, let me know if you have made any progress beyond this solution, please!

Thanks


#3

This is a bit old. But it caught my attention as I am getting ready to do the same. I tested in the current release version of 2018 and it seems to work. If there are more details you can provide (or even a scene) I can test again.


#4

@cineartist Thank you for replying. I too have managed to get it to work, only once I adjusted the default preference in Maya 2018, under Settings>Animation: Evaluation mode: Parallel to DG. When set to Parallel, it does not seem to work correctly in the current release.


#5

I wonder if the default changed from 2017 to 2018?

For what its worth I did not change any defaults. It just worked. I will check it again and look at that setting.


#6

There were some changes to how invisible object evaluate in Parallel mode in 2018. You could probably also workaround this by going to Evaluation settings and toggling off ‘Invisibility’ in the options.

This new option can make some rigs faster… others it breaks :slight_smile:


#7

hey guys,
at the moment with 2018.4 seems going good, maybe with new alembic version that problem was fixed (abc 1.7.5)
thank you for all reply, interensting “insibility off” Brian, as usual :slight_smile:
where can i find “invisibility”?