2012 Service Pack 2 is out


#137

Thanks for the response Ken, but I wasn’t asking you really anyways. I assumed one of the users who mentioned that they are experiencing the issue or have had discussions about it would respond.

I’ve looked back through this thread and, unless I missed it, haven’t seen anything regarding the Multi/Sub Object Mat problem before the last few pages, and none of those posts really gave any detail.

Like I said, I don’t know where to start looking when the only information I have is “Multi/Sub Object Problem”. shrug


#138

From what I have read, it’s an issue of how long it takes to open a file that uses a huge MSO material. Also the time it takes to start a render. But I haven’t experienced it firsthand (not using 2012 unless I have to), so maybe I’m wrong about that.


#139

Not opening the file, but the “translation/scene prep” for rendering.

-Eric


#140

Not sure about that, but is the problem only happening when rendering with Mental Ray ?


#141

As said above, the translation/scene prep" time before mentalray start to render is the problem.
The translation time escalates with big scenes.

The problem at work: We have a Multisub material with 100’IDs at work and we also have large scenes with alot of mesh in it. The problem happens with SP2 or Subscription Advantage Pack installed and not with SP1. (At the moment we are on SP1 and waiting for a hotfix :slight_smile:


#142

I’d also like to know if it applies to all renderers or mray only…


#143

Thanks for the responses everyone!

That is definitely what my problem was the other day - long translation time - so now at least I know it wasn’t something I did wrong. :hmm:


#144

Yep thats what it was. I just confirmed it through my reseller


#145

No update on this, after a half year?


#146

It seems to be fixed in max 2013 but afaik there was/is no info available on a fix for max 2012.


#147

Money, money, money - OUR money…

Why fix something for free, when you can sell it as Max 2013?


#148

AFAIK
Ken stated somewhere (i think in the 2013 announcement thread), that there is an update in the works for 2012. No release date or so given, nor if this specific bug will be fixed or not …

EDIT:
can’t find the info right now, so maybe i was just dreaming and my memory is playing tricks on me


#149

You mean #136: http://forums.cgsociety.org/showpost.php?p=7219503&postcount=136 ?

I am wondering that AD need so many times to fix a problem that was introduced in a service pack… Does they have so little man power with the how-to to fix a bug?


#150

The bug was in mental ray, not max. Therefore we had to have others fix it and then we had to integrate the new changes to the mr build. If you’d stop assuming that everything is trivial to do you’d probably have better expectations about how this stuff works.

I’m 90% sure it is scheduled for our 2012 SP. Yes, we fix “old” releases despite our money-grubbing ways.


#151

Ahem…don’t you mean current releases…:wink:


#152

This fix is indeed in the next 3ds Max 2012 Update. The defect is: MAXX-5824 - Major increase in translation times with multi-sub materials in mray

It was fixed in the 3ds Max 2013 code and was then cloned to the 3ds Max 2012 update code branch and is set as closed/fixed.


#153

The issue causes a huge slow down when opening the material editor too.


#154

So we have not installed anything other than the first hotfix, mainly because we keep hearing that this is slower or that doesn’t work now, or multi-sub materials are now slow…
Is there any kind of projected date for the latest SP for product update for 2012?
Will the latest HF/PU address the dreaded viewport lag?

We have been out of the loop a bit with crazy deadlines etc…

Thanks,
David


#155

has anyone else noticed a longer start up time with Max 2012 after PU-6?
Not a big deal, just wondering if it is just me.
David


#156

Yep, after loading of plugins is completed the splash screen sits there for much longer than previously.