2010 Viewport Redraw Issues on Object Creation


I am just curious if anybody else is having this problem. I have been running into it consistently for the first hour of playing around with 2010, and if its an actual bug its a pretty bad one. Not very good first impressions of the new Max, unfortunately!

I have been having big problems with viewport redraw on object creation through script. It seems like it might have something to do with when the new objects are being created on top of other objects. Anyways, it is incredibly annoying.

The simplest example I have come up with to work on a consistent basis is the following…

for i = 1 to 10 do box pos:[i*10,0,0]
for i = 1 to 10 do box pos:[i*10,10,0]

The first line of boxes gets created, but the second line does not. The objects are only finally drawn once the viewport is panned or timeline is scrubbed. I have tried calling on redrawViews, but only a completeRedraw seems to work.

Anyways, I am unsure at this point if this is a common bug or just something to do with my budget laptop. All I know is this works fine with Max 2009. Let me know how it works for you.


I can confirm.

I can even go a step further. If you maximize your perspective neither draws.


My guess would be that it has to do with the DirectX cache. What happens if you change the state of the DirectX cache and run it again?


It doesn't even show when creating just a single box or point. Snap..
 How would I go about doing that?  Haven't really played around with DirectX much before, sorry.


Ironic. MAX can’t handle MAXimized windows! Feel free to use that pun.


Unless they’ve moved it…
Customize > Preferences… > |Viewports| > {Display Drivers} > [Configure Driver…] > [ ] somethingsomething cache.


completeRedraw or nodeInvalRect works

for i = 1 to 100 do box pos:[i*10,0,0]
for i = 1 to 100 do (b = box pos:[i*10,10,0];nodeInvalRect b)

dx cache does not make a difference but, its about directx without a doubt :

customize/preferences / viewport / configure drivers… :

›› Check Redraw Scene on Window Expose

…and it works again


Nice, that worked!


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.