10.5 Leopard and Cinema


#1

Hey guys,

Anybody else using this combo yet notice any glitchiness with their system when rendering in Cinema? - I have an 8-core Mac Pro, which is rendering a high res render fro print - it’s running at about 700+% across the 8 chips, and performance elsewhere (iTunes, Web, screensaver etc) is really glitchy and stuttery! - this didn’t happen under Tiger whilst still running at the same speeds - it makes it feel like I am on an underpowered machine again! :confused:

Anybody else seeing this?

Adam


#2

Hey Adam - I imagine you’ve considered this, but one problem might be that after installing the disks have to indexed - this can take hours if the disks are big/full, or if there’s been a lot of installs recently.

Chris


#3

I haven’t put Cinema to that big a load yet under Leopard. But, in normal use things have been just fine here on my antiquated Quad G5.


#4

Me to!
I have the same setup as you, an 8 core with Leopard where Cinema seems to grab every clock cycle when rendering. Every other app just crawls, even Finder has a hard time. Something must be fishy here…

Anders


#5

is their any hair in your render and are you using 10.5 out of curiosity?

Hair is fully multithreaded and hair when rendering isn’t like the rest of cinema in that it is greedy and doesn’t leave much processing left for other things, you wouldn’t have noticed this before because it wasn’t using all the cores but would now since everything is being utilized by hair.

If no hair, then I’m not sure what else would be that greedy, sorry if i’m waaaaaay off target, just been doing a lot of hair myself so I’m blaming it for everything.


#6

Hey guys,

Thanks for your replies!

Chris - no, indexing was all completed yesterday, so that’s not the culprit :confused:

Delinos - glad to see it’s not just me then! - I have noticed some glitchiness on my MacBook Pro also btw.

Kai - No, no hair in this one - just some GI and the usual really. Not something that would have caused Tiger to strain elsewhere anyway - I have seen rendering taking up almost 800%, and still had no grumbles from elsewhere on the machine runing Tiger under normal use.

This is not a good start for what is otherwise a nice OS upgrade!

Would be good to hear if anybody else has experienced this and on what machines!

Adam


#7

Have SystemPrefs -> Energy Saver -> Options ->Processor Performance been set back to the default “Automatic” maybe?
At least in Tiger I set it to “Highest”.

Cheers
Lennart


#8

Lennart - thanks for your reply, but no that doesn’t apply in the Leopard Energy Saver panel.

Adam


#9

I guess this is a warning to not upgrade to Leopard yet?
I have my box still eagerly waiting to be opened, but by reading this report I guess it’s better to leave it untouched for a while…

odo


#10

I installed Leopard on 2 MacPro quads and a MacBookPro and a G5, three of them I had to install twice because all I got were blue screens after the install. The MacBookPro lost it’s administrator privileges and seems to be dog slow compared to how it was. The MacPro’s on the other hand feel really zippy. I have not done much rendering yet but I will let you know if there is any loss of speed.


#11

What’s the state of the “Adapt Thread Priority” checkbox in your preferences? If switched on, Cinema will get a higher priority (look into the Help for more details) than other apps.

Best regards,

wbj


#12

This is a rather annoying problem. I get better performance in other apps if I hide Cinema during a render with Spaces turned off. It also seems to interfere with itself, I got a crash when choosing the Help menu. I will try the thread priority thing suggested by wbj.

Anders


#13

Anybody having problems with the Screen saver or Monitor sleep mode when running Cinema, mine will not work


#14

It was on (as it ever was on Tiger), but I just tried it with it off (and a relaunch of Cinema), and it’s the same. :confused:

Adam


#15

So I guess the big question is: Is this something that needs to be adapted/rectified in Cinema itself, or is it purely the OS itself?? - I suspect the latter, but either way - I hope someone sorts it soon :]

Adam


#16

If “Adapt thread priority” is switched off, it 's up to the OS to manage the priority of the apps (Cinema doesn’t alter the priority in this case); the thread scheduling is a part of the OS, which was changed in Leopard by Apple.

kromekat, could you send a sample scene via maxon’s support? I can’t reproduce this on a quad or duo intel machine (at least not with the scenes I have on this machine).

Best regards,

wbj


#17

If “Adapt thread priority” is switched off, it 's up to the OS to manage the priority of the apps (Cinema doesn’t alter the priority in this case); the thread scheduling is a part of the OS, which was changed in Leopard by Apple.

Adam, could you send a sample scene via maxon’s support? I can’t reproduce this on a quad or duo intel machine (at least not with the scenes I have on this machine).

Best regards,

wbj


#18

It seems that Maxon isn’t the only one. From the Cow admins.:

For those who work with Adobe CS3 tools, please be aware that the new Apple OS 10.5, Leopard, does NOT work with most of the pro applications in CS3.

Adobe says: “…the following CS3 applications will require updates for full compatibility with Leopard: Adobe Acrobat 8 Professional and our professional video applications, including Adobe Premiere Pro CS3, After Effects CS3 Professional, Encore CS3, and Soundbooth CS3. We expect to publish free Leopard compatibility updates for the video applications in December 2007 and for Acrobat 8 Professional and Adobe Reader 8 in January 2008.”

Adobe has a PDF on the subject at:
http://www.adobe.com/support/products/pdfs/leopardsupport.pdf

Again, please be aware of this limitation, which Adobe says will not be fixed before December '07.

Best regards,

Your Friends at COW Central™


#19

I geuss i’ll also be putting off the upgrade for a while then, i nearly did it last night…


#20

I’ve noticed this too (on a dual 2.3 GHZ G5, 2GB RAM, Mac OS X 10.5). It probably does have to do with the new hierarchical thread scheduling in 10.5.

I notice it especially when render scenes are “preparing” (preparing geometry, rendering shadow maps), i.e. just before the render actually starts. For me, once the render lines are visible, other apps behave normally. Then it "freezes again when the next frame prepares.

It would be nice to get this resolved pronto…

Nick