LightFog with mib_light_spot problem

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2011   #1
LightFog with mib_light_spot problem

Hi, I'm having an issue with making light fog with a spotlight, using the mib_light_spot. I haven't run into this in the past because I haven't had to make shadows with light fog.

I've used this as a guide:

http://download.autodesk.com/us/may...ber=d0e5 12004

And it takes you step by step through the process.

But no matter what I do, I get this ugly jagged looking stair-stepping mess:



I've tried everything I can think of to fix this, but nothing seems to work. I can make the shafts disappear, or have them turn into a big miasma of fog through the whole scene, but I can't get clean shafts with decent shadows, not without these weird artifacts.


Any help would be greatly appreciated!

Maya 2009 with Mental Ray.

Last edited by Inky99 : 01 January 2011 at 04:59 PM.
 
Old 01 January 2011   #2
Have you played around with the depth jitter and volume samples parameters?
__________________
This should take less than a few minutes.
 
Old 01 January 2011   #3
Yeah, tried both of those things. Like I said, I tried everything that it seems can be tried, in the mib_spotlight attributes, the maya spotlight attributes, the cone attributes, the lightfog attributes, and the depth map shadow attributes! I also tried to do raytrace shadows, but I get the same result.

I feel like I must be missing something somewhere.

I also tried to ramp up the render settings to "production". Didn't have any affect.

I can either make the fog turn into one big fog thing with no shadows, or I can make the fog go away completely, or I can make the shafts, as you see in the photo, get less opaque, but I can't clear up those jaggedy-looking things.
 
Old 01 January 2011   #4
okay ....

This is driving me further nuts.

I finally figured out how to get an acceptable shadowed beam of fog.

But now? I can't get more than ONE in a scene.

I make a light, get a decent shaft of fog out of it, that goes through a window and makes a beautiful shadowed pattern from the window ...

Then I dupe it ...

And the 2nd light will not have any fog. I mess around with the settings, then suddenly the 2nd light has fog, but the first one will not.

Doesn't matter how I dupe it. If I instance it, or just straight dupe.

Even if I create a 2nd light with Lightfog, the same way, only one will show fog, the others will not.

They all connect to the same Shading Engine. This may be part of the problem? I don't know.

Driving me batty ....
 
Old 01 January 2011   #5
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:46 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.