Mirror Joint tool not mirroring Behaviour

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2010   #1
Mirror Joint tool not mirroring Behaviour

Hey guys,

I am in the process of rigging one of my character models, and I cannot figure out what exactly I am doing wrong. I have my joints oriented , and half of the skeleton set up and when I attempt to mirror the arms and legs over to the other side the behaviour is not mirrored despite my having checked off the box in the option box.

So for example if I select both arms at the shoulders and rotate in, the right arm rotates in across the body where as the left arm rotates out to the side of the body, instead of mirroring the right arms behaviour.
.
I am using Maya 2011.

I am fairly new to rigging so this is probably a very straight forward and easy problem, but I haven't been able to find any issues like this online despite my many attempts.

If anyone could help it would be greatly appreciated.

Thanks!
 
Old 06 June 2010   #2
Without seeing a screen shot it's sort of a guess at what might be happening. So let me detail how I might mirror my joints.

I'll build out the arm and then name the arm. (Usually I use a naming convention that leads with L_ or R_ for left or right.)

I will then parent that arm hierarchy into the spine where I want it. Usually to the clavicle then the clavicle to the Spine_Chest.

Then I click on the Clavicle (the first joint in the chain for the arm) and select
Skeleton > Mirror Joints > Optionbox.

With the option box window open I will set the name replace to be L_ to R_ this will reduce the amount of renaming that you have to do. Also you can select to Mirror Behavior here. So that the joints will mirror their actions.

Ususally I am setup so I can use the YZ axis Plane you may have to experiment to find the right plane axis for your rig.
__________________
There is no one right way to do anything.
Only the un-explored ways. =)
 
Old 06 June 2010   #3
Those are pretty much the same steps I am taking.

Here are some pics.

The first pic I checked off behaviour for the mirroring, and the second I chose orientation.

Both give me the same outcome with the way the arms move. Behaviour should give me mirrored movement. So the right arm moves in then the left arm does the same thing. At least that is the way it worked in 2010 and older.

behaviour




orientation

 
Old 06 June 2010   #4
I think that it's your Rotate Tool's rotation mode. It looks like it might be set to "Global". Change it to "Local" or "Gimbal" and you should see the correct behaviour.
 
Old 06 June 2010   #5
Thanks Gonzalimator, that fixed it.
 
Old 06 June 2010   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:11 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.