Shadow Map Flicker - Just cant figure it out...

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  05 May 2010
Shadow Map Flicker - Just cant figure it out...

http://www.youtube.com/watch?v=RQ_aA7ax17k

underneath the right ear some strange black artifact is flickering on and off. I made a thread that included this question but there have been no solutions to solve the flickering.

My new shadow settings are:

Detail Shdow Maps

resolution 1024
samples 32
softness .020
bias .01


However im not sure this is a shadow problem, i tried rendering the scene without the hair, on a normal blinn surface with the same light setup and the artifacting is gone. This makes me think the problem lies within shave and a haircut?

Im using mentalray, rasterizer rapid hair preset. Using hair primitives as the hair render mode.

Please please please help!

ps, no "use puppet shader" responses please
 
  05 May 2010
Wery short and low quality video- difficult to recognize problem.
It is not recommendet to touch bias, so any way set bias=0. Shadow flicker cures by rising samples in detail shadow map section.
__________________
3D animation blog
 
  05 May 2010
thanks for the advice.

Well, i removed the shadows completely from the scene and the black artifact is still there. so apparently this has nothing to do with shadows at all, and is a shave and a haircut problem. cheers to another can of worms.
 
  05 May 2010
UPDATE:

So ive started to tweak a setting at a time, isolating the head so that it wouldn't take so long to render as i troubleshooted each setting. To do this i lowered the hair count to 1 on all hair systems but the head and chest. In doing so i noticed something... The artifacting was gone.


Simply by lowering the hair count on the leg and arms hair systems to 1 hair each. The artifacting in the head system is gone. So, shave gurus... What exactly is my problem here, if this solved the problem (of course introduced a new one)

Heres a before and after:





its a bit difficult to see whats going on, but there is a dark edge underneath the bears right ear, if you quickly jump back and forth with your eyes you can see the difference. Seems subtle but during animation when viewing it high def it sticks out like a sore thumb.

Last edited by Stellios : 05 May 2010 at 10:08 PM.
 
  06 June 2010
problem was soved by increasing the voxel resolution in the shave globals.

 
  06 June 2010
From now you definitely need to setup scene with p_Hair_TK and compare results
__________________
3D animation blog
 
  06 June 2010
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:24 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.