Fbx export from Modo crashes Maya

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2010
Fbx export from Modo crashes Maya

How come every time I save out something from modo as fbx and open it up in maya, causes a fatal error, every time I want to make anything to the mesh?

Obj export looks like it's working fine, only it exports everything as one object. I preffer fbx, though. because of multiple uv sets
__________________
the one button to render them all
 
  03 March 2010
I have never tried to import fbx files into Maya. Importing them into XSI works fine though, never experienced any crashes.

There seems to be something weird going on with UV sets and fbx files from Modo though. Although all objects only had 1 UV set in Modo, after importing the fbx file into XSI there suddenly were about 10 UV sets, partly with an actually UV layout/ projection in them that I definitely never created. Just a minor nuisance, deleted the extra ones and that was it.

No idea if Maya crashing has anything to do with that. Maybe check for UV sets that you haven't created and delete those before doing any edits to the mesh.

You could also try to import the fbx into blender and see if it also crashes (there is a fbx file importer for Blender I think). Export it again from Blender and try to import that new file into Maya.
 
  03 March 2010
Thanks.
I think i kinda solved the problem myself, I went to Geometry>Polygons>Unify. This solved the crashes. Looks like modo is creating some polygons where there shouldn't be.
__________________
the one button to render them all
 
  03 March 2010
I recently added modo to my pipeline of work for modeling, uv and texturing

I wanted to test out the compatibility of modo to maya.

What I did is created a simple cube in modo, exported it as fbx and import it into maya.

For some reason, I can't see anything at all. I can see a mesh imported into the outliner, but I couldn't see anything in the viewport.

I am wondering if there are few logical steps to take to maximize the compatibility of modo output to maya.

Thanks
__________________
www.artbyfranklin.com
 
  03 March 2010
check the units. isn't the cube too big?
__________________
the one button to render them all
 
  03 March 2010
should make sure the units measurement match in both programs?
__________________
www.artbyfranklin.com
 
  03 March 2010
i just make sure they are both in meters, but its still the same.

when I press F in maya to center the object, it shows up for one second and it disappeared, what does that tell me??
__________________
www.artbyfranklin.com
 
  03 March 2010
Originally Posted by MileDream: i just make sure they are both in meters, but its still the same.

when I press F in maya to center the object, it shows up for one second and it disappeared, what does that tell me??

Two things when working with Maya and FBX is to bake your whole animation, that is why is showing the one second you are animating or maybe in your you have the timeline setup for one second.
ANother is to try to export as OBJ not FBX and if you do so than select the object you wish to export making sure there is not animated for cameras works when you baked your camera animation to frames.
Try that and let us know.
Edgard
 
  03 March 2010
Originally Posted by MileDream: i just make sure they are both in meters, but its still the same.

when I press F in maya to center the object, it shows up for one second and it disappeared, what does that tell me??

yeah. is the camera clipping. you have to select the camera, go to the attributes and set the far clip plane way higher. just add one more zero, You should add one for the near clipping too, otherwise you may see artifacts.
thing is, the cube is way too big.
__________________
the one button to render them all
 
  03 March 2010
yes, i found out the cube was indeed too big, for some reason the cube measurement was in km, even thou I set the standard to meters under preferences.

can I ask what does baking the animation do? I have a little technical knowledge gap to bridge, so forgive me for asking silly questions.

i think using obj isnt an viable option, since I am currently working under a modo - maya - 3dsmax workflow and I need to include all the mesh, texture, animation information.
__________________
www.artbyfranklin.com
 
  03 March 2010
Originally Posted by MileDream: yes, i found out the cube was indeed too big, for some reason the cube measurement was in km, even thou I set the standard to meters under preferences.

can I ask what does baking the animation do? I have a little technical knowledge gap to bridge, so forgive me for asking silly questions.

i think using obj isnt an viable option, since I am currently working under a modo - maya - 3dsmax workflow and I need to include all the mesh, texture, animation information.

Records the position/scale/rotation/point level animation/etc in time of every frame of the animation of a selected object such as camera,lights,meshes these saves you for complex simulations such as IK solvers,particles simulations,etc.
If you want to scrub the your animation timeline and check for details these is the best approach to avoid further calculations.If you want to render out a simulation over a network is also recommended perform these type of operations.

There could be a far better extended explanation but these what the basic concept is.
Edgard

Last edited by ediris : 03 March 2010 at 03:47 AM.
 
  03 March 2010
isee, thanks for your explanation
__________________
www.artbyfranklin.com
 
  03 March 2010
Lightbulb Pretty sure stray vertices cause this .fbx issue...

Originally Posted by Leionaaad: Thanks.
I think i kinda solved the problem myself, I went to Geometry>Polygons>Unify. This solved the crashes. Looks like modo is creating some polygons where there shouldn't be.


From what I've read around the forums is that having any lone/floating vertices in your Modo scene will cause problems when exporting/importing .fbx's between Modo and Maya. It will cause Maya to crash. Deleting polygons in Modo will remove the polys but leave the vertices in place - so I usually just select/remove the stray verts via the statistics window before exporting.
 
  03 March 2010
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:55 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.