Mia_Exposure_Photographic - Simple Question

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Search this Thread Display Modes
  11 November 2009
Mia_Exposure_Photographic - Simple Question

Okay, so I've setup my sun and sky, then deleted the mia_exposure_simple and replaced it with a mia_exposure_photographic. My render looks fantastic, but theres a slight problem. Even the image plane thats connected to the camera is effected by the lense shader. Now, its quite difficult to colour match the geometry to the image plane.

Is there anyway that I can have the lense shader only effect the 3D geometry, but not my image plane, instead of flipping to another frame buffer which already has the background image loaded ?

Thanks in advance.

- K
  11 November 2009
It is annoying and you can't actually tell the lens shader (or image plane) to ignore it, but you can set the image plane to 'texture' mode instead of 'image file', and that way you can use the gammaCorrect node as you would with your textures to de-gamma the image plane. Of course.. that means the image plane will look wrong in your viewports. A way around *that* is to use the 'pre render MEL' and 'post render MEL' features in the Render Settings to change the gammaCorrect's values for you.

As in 'pre render MEL' sets the gammaCorrect to 0.454 and then the 'post render MEL' sets it back to 1.0.

~ Jared Martin

Maya, 3Delight, mentalray, Maxwell Render, ZBrush
Photoshop, Fusion, Vegas Pro, Syntheyes
  12 December 2009
Hi Jozvex,

Long time no see, and thanks for the reply.

I did try the file -> gamma -> image plane, but it didn't seem to work as I think the shader does more than just change the gamma. The iso, shutter speed, cm2 sturation all play a part in the final outcome of the image.

Oh well, back to the drawing board.

  12 December 2009
the way i got around this problem was to put the image plane on its own render layer, with no lens shader applied on that layer. put this layer underneath your beauty layer in the stacking order. then under the render layer options, choose "render all layers" so that your tonemapped image is composited on top of your original image plane with the colors intact.
  12 December 2009
Thanks for the tip.

Will give it a try.
  12 December 2009
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 11:00 AM.

Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.