particles stick to surface UV problem

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2009   #1
particles stick to surface UV problem

I am trying to get my particles to stick to a soft body. I got it to work just fine in a test scene.

(Im using 2008 particles) I emit particles from the surface of the object which is a polyPlane and my particles have the creation expression:
.goalU = .parentU;
.goalV = .parentV;

works like it should in my test scene, but in my regular scene the particles just go to the verticies and dont even stick. I did a geometry cache in case that was the problem but no luck.

If I turn off the goal my particles emit from UV's like they should.. so im not sure whats going on, has anyone else had this problem?
__________________
This could be your cake.
 
Old 11 November 2009   #2
check your emitter.. make sure "Need parent UV" is checked on.
 
Old 11 November 2009   #3
yup its on, even when I print the uv values they look appropriate.
__________________
This could be your cake.
 
Old 11 November 2009   #4
Ok.. I made some quick test.. and did have the same problem as you with the particles sticking to the vertices.. a workaround I found is the following:
Create a geometry cache for your softbody and delete the particles (It already has some particles attached to it... wich is what makes it a softbody)
Make the geometry to emit particles , make the geometry a Goal and write the creation expression as you would normaly do.
Probably not the best way but seems to work for me

Hope that helps

Edit... after reading your first post.. again.. I realize that my "magic workaround" of creating the geometry cache is something you already done, and still have the problem ... So I ran out of ideas.. can you post your scene to check it out closely?

Last edited by TheRispo : 11 November 2009 at 07:35 PM.
 
Old 11 November 2009   #5
heh yep your right, maya conveniently uses the soft body particle as the goal by default rather than the mesh. It wasnt working for me because the 2nd time around I didnt delete the particle I just disabled it.. silly me.

Thanks TheRispo
__________________
This could be your cake.
 
Old 11 November 2009   #6
I'm going to do away with my geometry Cache for now so I can continue to tweak the animation and just force the surface particle connection to the mesh in the hyperGraph
__________________
This could be your cake.
 
Old 11 November 2009   #7
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:21 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.