No shadows appear in Renders, but they're switched on!

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 08 August 2009   #1
No shadows appear in Renders, but they're switched on!

Hi, I'm having a strange problem in Maya and Mental Ray, I have a Direct light for Sun, and I have raytraced shadows switched on but when I render just using GI and not FG no shadows appear. Why is this?

Thanks
 
Old 08 August 2009   #2
Version?

Which Maya version are you using?

Perhaps post a render so we can see?
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 08 August 2009   #3




Here's a render, and a screen grab. I'm using Maya 2008, I don't know why no shadows are being cast, its very strange. Do you have to render with FG turned on to see shadows? The FG renders take too long.

Thanks for the help
 
Old 08 August 2009   #4
Are the shadows enabled in the render globals as well?
 
Old 08 August 2009   #5
Also, your ray depth limit is way too high unless you have an insane amount of transparent surfaces hidden in that landscape...
 
Old 08 August 2009   #6
Looks like there is a giant sphere enclosing the scene. If this sphere casts shadows it will block light and shadows from the directional light to enter the scene.
If this is the case uncheck 'Casts Shadows' under Render Stats on the sphere.

/eric
__________________
color-department.blogspot.com
 
Old 08 August 2009   #7
Agreed. Hopefully it's as simple as adjusting your environment sphere.

Also, FG should never take "too long". It's highly tweakable and you should be able to experience very fast FG if your settings are proper.

Those ray-depth settings are seriously absurdly high, especially for a scene with no complex glass or gems!
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 08 August 2009   #8
Stefan, probably not the appropriate place to ask but i mailed you acouple of days ago asking if you had a tutorial about celulite with no answer.. Did you have one or no?
 
Old 08 August 2009   #9
Originally Posted by Sybexmed: Stefan, probably not the appropriate place to ask but i mailed you acouple of days ago asking if you had a tutorial about celulite with no answer.. Did you have one or no?
Celulight is not publicly available so I don't see the reason for a tutorial.

Sorry for going off topic.
 
Old 08 August 2009   #10
Hi, thanks epq! That worked, I forgot about the Sky sphere casting shadows. Its all rendering correctly now. Cheers
 
Old 08 August 2009   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:17 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.