CGTalk > Software > Autodesk Maya > Maya Rendering
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
Thread Tools Search this Thread Display Modes
Old 06-17-2009, 12:29 PM   #1
New Member
Timo Rychert
Reykjavík, Iceland
Join Date: Mar 2008
Posts: 12
Use Background Shader visible in Reflections?

Hello CG Talkers.

I am new to Maya, working on my first animation project and now I came to the render part.
I am using the "Use Background Shader" for my ground plane to create an infinite white world, but still being able to receive shadows on that plane.

Everything works fine except that when I put in a reflective object it reflects the ground plane as if it had a regular shader and not the "Use Background Shader". That means the horizon is still visible in the reflection while it is invisible in general. I have attached a screen shot in case it is not quite clear. The rainbow should be reflective in this case, but it should only reflect the shadows on the ground plane not the geometry of the ground plane itself (which it quite clearly does as you can see by the reflected horizon line).

The only solution I came up with was to turn off "Visible in Reflections" in the planes Render Stats tab, but that unfortunately also gets rid of the shadows in the reflections and I would like to keep those.

Is there a way to work around this? So still have a reflection of the shadows, but not of the plane itself.

Thank you in advance,


Edit: Sorry, forgot to mention. I am rendering with mentalray and using Final Gathering, if that's important.
Attached Images
File Type: jpg ReflectionProblem2.jpg (37.1 KB, 42 views)
Old 08-27-2009, 07:13 AM   #2
eikonoklastes's Avatar
Join Date: Oct 2008
Posts: 551
Select your ground plane. Open the Attribute Editor. Open the Shape node. Under Render Stats uncheck Visible in reflections.

Cancel the above. I'm sorry, I didn't read your post carefully enough.

Last edited by eikonoklastes : 08-27-2009 at 07:18 AM.
Old 08-27-2009, 12:08 PM   #3
swashing my buckle
seandunderdale's Avatar
Sean Dunderdale
3d Artist
United Kingdom
Join Date: Jan 2006
Posts: 391
Send a message via MSN to seandunderdale
the background shader can be flakey...Id avoid it if possible.

What Id do is make a shadow pass render layer. Give your floor a white lambert shader, select all your objects in the scene (whilst having the shadow render layer selected) and turn off the primary visibility in the attribute spreadsheet. When you render out your beauty or whatever, and then your floor shadow, you can just make a grad or flat colour backgound in your compositing package, and multiply the shadow onto that, giving you your infinity cove effect.

Im not young enough to know everything...

Old 08-29-2009, 01:23 PM   #4
New Member
Tan Xin
Shenzhen Polytechnic
shenzhen, China
Join Date: Jan 2003
Posts: 5
Adjust the 【Attributeuse】of【Background Reflectivity】to “0”,done.
Old 08-29-2009, 01:23 PM   #5
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
Join Date: Sep 2003
Posts: 1,066,478
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 11:09 AM.

Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.