Bind pose issues

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 07 July 2003   #1
Bind pose issues

I am still comming to grips with maya, comming from a max background, so please don't yell at me :P

Okay here is my issue, I am having problems comming to grips with the workflow of creating a character rig that can easily be switched in and out of bind pose? In max I used to be able to put my character in to "figure mode" at any time and do things like rigging fixes and and model changes, is there any easy way to do this in maya?

I have yet to find a rock solid workflow I can trust, which as you can imagine is pretty scarry in production...

If someone could go though this with me I would be very very happy

Thanks,
__________________
GENESIS
 
Old 07 July 2003   #2
When we set up characters, we make sure that if you zero out the translation and rotation of the control, then the character is put in the bind pose. You can do this by freezing transforms, or by putting another null above the control, and then using that null to orient and position the control.

Also we always reference our rigs into a scene for animation, so the original rig file is always in the bind pose. We may put some temporary animation on the rig during testing, but we key the first frame at the bind pose, and do our test animation after that. To get rid of the animation we go back to frame zero (the bind pose) and delete all animation keys from the timeline.

We also ran across problems with geometry contstraints not zeroing out, thus any skinning changes complain that the rig isn't in the bind pose when we try to add influences. When this problem pops up, we simply delete the bind pose node.


Hope this helps,
Michael Duffy
mduffy@ionet.net
 
Old 07 July 2003   #3
Thanks for your help, I will have a play with what you have mentioned. It still seems rather complicated compared to the simple way it was done in max. Oh well, I guess that is just part of the learning that goes with changing programs

Thanks again for your reply, I am sure it will be of great help.
__________________
GENESIS
 
Old 07 July 2003   #4
I think you will find that if you use Modify> Evaluate nodes >Ignore all, your problems will be solved in most cases but to be safe, as MDuffy says zero out your channels . There are some scripts on highend called Record BindPose or something along those lines which record all the chanels values from your entire heighrachy once you execute the script...just copy the results out your script editor and mid mouse drag on to your shelf for an instant return to bindpose button,...there are a few on highend3d so check them out..
 
Old 07 July 2003   #5
umjetnik,

You the man, that sounds exactly what I am after, thanks heaps.
__________________
GENESIS
 
Old 01 January 2006   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:04 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.