Python not recognized with Xsi 7

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 08 August 2008   #1
Python not recognized with Xsi 7

I've installed Python, and PyWin32. I've run the suggested com extention script mentioned in the xsi guides docs. But despite all that xsi doesn't seem to want to list Python as a scripting language under preferences, and when I try to load python based plugins it gives me an error saying that they are invalid. Anyone have any ideas why python is not showing up?
 
Old 08 August 2008   #2
Only thing I can think of is that you might have got the wrong pywin32. You need to get one that ties to your python version for it to work correctly.
Normally installing python first then pywin is all you need to do.

Uninstall/reinstall is also an option, python is fairly thorough in cleaning after itself when you uninstall, so it's viable without ending up with a ton of registry and configuration garbage.
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
Old 08 August 2008   #3
Are you running x32 or x64?
 
Old 08 August 2008   #4
I checked the pywin32 version and it seems to match the version of python I installed (2.5) -- I uninstalled and reinstalled and still nothing shows up.

I'm running x32

- S
 
Old 08 August 2008   #5
Check softimage's wiki, there's an article on it on how to get python running.
I never had those problems so I'm not sure I can really help.
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
Old 08 August 2008   #6
Yes I read the wiki docs and the xsi guides etc.. Maybe I'm missing something crucial but so far I haven't a clue. It seems like I've done everything that I'm supposed to do or that they suggest trying. Python itself runs ok from explorer. Maybe if I had a better idea of how the two apps interfaced. I think it must be looking for some kind of registered COM object. If you're running python is it also version 2.5? And this is working with xsi 7?
 
Old 08 August 2008   #7
2.5 with pywin32 for 2.5 working fine here with v7, on xp32 and vista32.
The way they interface is through pywin32, which is a wrapper for the activestuff(tm)/COM architecture for XSI to interface with python.
First time I see somebody going through all the steps in the wiki and not getting it running, I'm just as stumped as you are sorry.
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
Old 08 August 2008   #8
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:15 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.