Disable Swatch Generation, Mia_X Material

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 12 December 2007   #1
Disable Swatch Generation, Mia_X Material

Hi!

In maya 2008, is there any way to disable swatch generation for the MentalRay Mia_x material in the hypershade? It doesn't seem to respect the "Disable File Load" attribute on the file texture nodes, and makes the hypershade extremly slow when working with multiple high res textures.
 
Old 12 December 2007   #2
I'm not sure about a toggle inside maya, but you can disable it more permanently by changing a line in D:\Program Files\Autodesk\Maya2008\scripts\others\mentalrayCu stomNodeClass.mel (dont change the original - make a copy to your local scripts folder and change that).

You need to remove ":swatch/mentalRaySwatchGen" for mia_material_x.
Change
if ($nodeType == "mia_material" ||
	$nodeType == "mia_material_x")
  "rendernode/mentalray/material:connection/mentalray/shadow:/connection/mentalray/photon:shader/surface:swatch/mentalRaySwatchGen";


to
if ($nodeType == "mia_material" ||
	$nodeType == "mia_material_x")
  "rendernode/mentalray/material:connection/mentalray/shadow:/connection/mentalray/photon:shader/surface";


-- David
__________________
http://www.djx.com.au
 
Old 12 December 2007   #3
Originally Posted by maya2008 docs: You can now set a maximum resolution for your Material Sample swatches. If your file texture size exceeds the specified resolution, a swatch will not be created until explicitly requested: in the Hypershade, right-click the swatch and select Refresh Swatch from the marking menu; or, in the Material Sample swatch in the Attribute Editor, click on the swatch to refresh the display. This reduces memory consumption and improves conversion time, increasing performance especially when dealing with many large textures. This is most useful for initial load of scenes with many large file textures. Once a swatch is created, it will always be displayed.

Select the maximum resolution from the drop-down list. You can also select the Custom option and enter the resolution that you like. File textures of a resolution above this value are not displayed in the Material Sample swatch in the Attribute Editor or in the Hypershade. The default is 2Kx2K.


you can find this switch in the Display Preferences window
 
Old 12 December 2007   #4
djx: Thanx! I'll try this

calinp: I have tried this, but it doesn't seem to work well with the mentalray shaders.
 
Old 12 December 2007   #5
You can try dragging 'custom' swatch from the renderview window, it may override the swatch generation
 
Old 12 December 2007   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:11 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.