Ambient Occlusion map giving me RED rendering errors.

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  11 November 2007
Ambient Occlusion map giving me RED rendering errors.

I'm having a problem with my Ambient Occlusion maps.
Whenever I render them out, they seem to have a bunch of red marks all over the map.

I'm using the render to texture option with mental ray as my renderer.
I made sure that my cage was reset and expanded to the proper proportions.
I'm doing this for a game model, using my high poly as a reference to my low poly game model (low poly contains the UV map fyi)
I also made sure to hide my low poly model before rendering out the Ambient Occlusion map.

I'm at a loss, anybody know of why these red blotchy errors are appearing?
__________________
www.davidopreska.com
 
  11 November 2007
Sounds like a cage error... I would double check it. Find the areas that are appearing red and where that spot coincides on the cage. Manipulate the cage verts there a bit and see if it changes anything.
__________________
My Portfolio
 
  11 November 2007
Red areas on your bake means that rays are missing.

Baking works by using a projection cage to project rays from it to the low poly mesh you're baking for. Any high poly geometry the rays hit are recorded (or baked) into the texture map (normal, amb occ, whatever).

Usually it means that you have holes in your mesh, but it can sometimes be that your projection range isn't high enough, therefore your rays are cancelling out and stopping before they actually hit anything to record the form from.

Hope some of this helps
 
  11 November 2007
Why not just use crazy bump? It generates some really good Occlusion maps imo.
 
  11 November 2007
Crazy bump can't render an AO from a high poly to a low poly. It only renders AO based of the existing texture if I'm not mistaken.
__________________
My Portfolio
 
  11 November 2007
It was the low poly messing up the AO map, BUT, I can't hide it.....

Hey guys,

Thanks for the replies.
Okay, so I've narrowed down the problem, but, I can't figure out how to hide the low poly geometry.
I hid the low poly geometry under the " Reference Geometry" tab located when you open up the render to texture options. (see attachment for more info)
Anyway, in the viewport it does hide the geometry, however, it's still showing up in the rendered out ambient occlusion map.
So, how am I supposed to hide the low poly geometry?
Attached Images
File Type: jpg low_geom_hidden.jpg (59.6 KB, 75 views)
__________________
www.davidopreska.com
 
  11 November 2007
Ah. Your high res / reference geo is occluding your bake.

The only way I've found to get around this in Max (I'm still on version 8) is to use light tracer with the scanline renderer.
 
  11 November 2007
Ah. Your high res / reference geo is occluding your bake.

The only way I've found to get around this in Max (I'm still on version 8) is to use light tracer with the scanline renderer when you render to texture.
 
  11 November 2007
You can use Object ID to exclude objects from the ambient occlusion shader. I can't remember exactly how it works, but there is info about it here and there if you do a search for ambient occlusion and object id.
__________________
Peter
_______
Environment artist blog - iPhone 2D Shmup Ultrablast!
 
  11 November 2007
Figured out the problem:

Alex Halchuk gave me the solution from the 3D Studio Max forums. So, if anybody else comes across this problem, here's your solution:

Posted by Alex:
"Neat little trick to fix is is by going into your low poly mesh. Go into polygon or element sub-selection and hit ctrl-a to select all the faces. Then hit hide selection in the command panel.

All of your low poly mesh should be invisible, but the object can still be selected and only your cage should be visible. Now if you bake the model it won't show up in the render and you'll get a nice clean result. When you're done, just go back into editable poly and click on unhide all."

Thanks for all the help!
__________________
www.davidopreska.com
 
  11 November 2007
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:08 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.