Particles wont collide with geometry

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 04 April 2003   #1
Particles wont collide with geometry

The scene is really simple and I can't figure out why this isn't working, I select my particleshape, then my geometry and go to Particles - make collide. But then when I play it and the particles emit into the geometry, they don't collide and they just go right through it. What am I doing wrong?

Any help is much appreciated

-Tom N.
__________________
AM Signing up January!!

ILM interview thread, useful info
 
Old 04 April 2003   #2
Did you checked dynamics reletionship editor? (or whatever its name)
__________________

Sorry for my
terrible English.

Sketch everyday
 
Old 04 April 2003   #3
It sounds to me like you're emitting your particles from inside an object? Is that the case?

If that's the case, it's because of the polygon normals. The normals need to face the particles in order for them to collide.
__________________
~ Jared Martin

Maya, 3Delight, mentalray, Maxwell Render, ZBrush
Photoshop, Fusion, Vegas Pro, Syntheyes
 
Old 04 April 2003   #4
>>josvez: The normals need to face the particles in order for them to collide.

that is not really true. although it is a good idea to have the normals in the right direction maya can and does handle collisions with objects that have normals facing in the wrong direction (can quick check that with a default poly sphere and an emitter inside.. works perfect for me.. i think you *can* get problems sometimes but in most cases it works.

Tom: what kind of geometry are you using? nurbs or polygons?

if it is nurbs you might have to increase the tesselation factor in the geoConnector.. but that should only make collosions better and not enable them..

do as augustus suggested: check in the dynamic realationship editor if the surface is really connected to your particles as a collision object..

you can post an image of your scene.. that might help seing the problem as well (or post the whole scene)

cheers

alexx

edit: one last thought: do you have your playback settings to: "play every frame" if not do so
 
Old 04 April 2003   #5
With regards to the normals issue - this is more of a problem when you're using soft body dynamics - I remembering spending a while trying to figure out why my dynamic ball passed straight through my ceiling (I hadn't turned the plane the other way up)
__________________
Hugh Macdonald
nvizible
 
Old 04 April 2003   #6
Oh ok,

Yeah I know I've had problems where the answer was the normals, so I just figured you had to have them face the right way!
__________________
~ Jared Martin

Maya, 3Delight, mentalray, Maxwell Render, ZBrush
Photoshop, Fusion, Vegas Pro, Syntheyes
 
Old 04 April 2003   #7
hmm i've tried all of those things except for the normals issue.. I'll look at it anyways.. I made sure that the particles are emitting outside the objects and i checked the dynamic relationships editor for collisions.. maybe its just my settings for resiliance and friction on the collision? i vaired them up a bit but still nothing made a difference tho.. hmm i'll try starting over, thanks for all the advice!

-Tom N.
__________________
AM Signing up January!!

ILM interview thread, useful info
 
Old 04 April 2003   #8
hmm.. resillence and friction wont help in that case..

can you post a small example scene? that would help in bug hunting for sure..

cheers

alexx
 
Old 04 April 2003   #9
Quote: I select my particleshape, then my geometry


I don't know too much about Maya particles, but i think you should select particle object, not particleshape node.
__________________

Sorry for my
terrible English.

Sketch everyday
 
Old 04 April 2003   #10
hey guys this is dumb but i restarted the scene and it all worked fine... thanks for the replies tho!

-Tom N.
__________________
AM Signing up January!!

ILM interview thread, useful info
 
Old 01 January 2006   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:11 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.