fade opacity??

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 08 August 2007   #1
fade opacity??

Hi there.
I'm trying to render particles as particle clouds feeding the clouds with a 3d fluid. With a default opacityPP ramp I fade the particles to 0. I the viewport particles fade to zero opacity, but not in rendered pictures. Actually opacity decreases but won't fade to zero at the end of the lifetime. Why is that? With a particleSamplerInfo I connected opycityPP with the transparency of the fluidShape, so I thought this would fade the clouds to 0 opacity...

Any hints?

Thanks
Rob
 
Old 09 September 2007   #2
Talking

I know this reply is very late but the values for the shader transparency and the particle opacity are inverted in relation to each other. So you have to run the particle sampler node into a reverse node and from the reverse node to the shader transparency. This way both values will match up and should see the correct opacity when rendered. I hope this helps.

James
__________________
My Homepage
My Vimeo Channel
 
Old 09 September 2007   #3
opacityPP on the particleShape only works with hardware rendered particles. Create a ramp on the life transparency of the cloud shader and it will work in software render. You'll always have to keep in mind that the opacityPP and life transparency are different ramps, so if you change opacityPP it won't show up in render, and if you change life transparency it won't show up in the view.
 
Old 09 September 2007   #4
Originally Posted by pgraham: opacityPP on the particleShape only works with hardware rendered particles. Create a ramp on the life transparency of the cloud shader and it will work in software render. You'll always have to keep in mind that the opacityPP and life transparency are different ramps, so if you change opacityPP it won't show up in render, and if you change life transparency it won't show up in the view.


There are two problems with this approach,

You have an extra ramp there taking up resources. it may not seem like much but on complicated scenes less clutter is always better.

The two ramps will not have the same values, so if you are trying to match up what you see in the viewport and your actual render then you will constantly have to change both ramps to the same values not to mention that they are inverted to each other.

The way I described above takes care of all of these problems, it will link both opacities and invert them at the same time. So you only have to worry about controlling one ramp.

Hope this helps

James
__________________
My Homepage
My Vimeo Channel
 
Old 09 September 2007   #5
As far as I know, cloud shader attributes won't respond to any particle behavior unless they're piped in with a particle sampler info node.

I always stick a ramp on opacityPP and then create a particle sampler info node, take the opacityPP from this node and stick that into a reverse node and then send the output into cloud shader transparancy.

I don't think ramping the transparancy on the cloud shader alone responds to the particle age. The only way to sample per particle attributes is with a particle sampler info node.

Last edited by thomwickes : 09 September 2007 at 12:20 AM.
 
Old 09 September 2007   #6
Originally Posted by hkspowers: The way I described above takes care of all of these problems

Sorry, I must have read over yours too fast to realize I was talking about the same thing you were. I did want to point out where the Life Transparency was though, I don't think delarge knew where to find that.
Originally Posted by thomwickes: I don't think ramping the transparancy on the cloud shader alone responds to the particle age.
Ramping the Life Transparency does.
 
Old 09 September 2007   #7
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:52 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.