mia_material interpolation error?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2007   #1
mia_material interpolation error?

I've noticed that on interpolated surfaces they sometimes produce artifacts like super bright odd colored pixels, but at double or three times the size of a typical pixel depending on the interpolation size.

Anyone else get this or know how to avoid it? I'm finding myself afraid to use interpolation now in case it produces errors.
 
Old 06 June 2007   #2
As stated in the docs, interpolation works better with flat surfaces...I use interpolation sometimes with rounded surfaces like cylinders or smoothed polygons and till now never had too much problems, just increase points at 4 and grid at 2.
You talked about 'interpolated surfaces' and don't know exactly what you mean, maybe a typing error but never had problems with overbright or odd coloured pixels.
Can you post an image or the interpolation parameters?
__________________
www.fabriziogambacorta.com
 
Old 06 June 2007   #3
I don't have a ton of images of the error cause I would delete or re-render the ones that got the error. But here is one I found http://x015.uploaderx.net/x/stillsB.11.jpg if you look at the mans righ thigh it has the one odd colored green pixel. Which is the size of the interpolated pixels for the blurred refraction.

Now I got these errors on any type of mix of interpolated surfaces, whether or not they have just interpolated refractions, interpolated reflections or both. The other thing about it is, they seem to be completely random, re-rendering the same shot would not produce the same error in the same spot or color, but the error is bound to specific surfaces (ones with interpolation). The error could also show up any color of any intensity, that one is green, perhaps it's somehow getting that from the grass texture. I've had it show up as black spots or super overbright white spots in an HDR render. They can come in single pixels like that one, or clumps. They aren't NaN pixels like the typical black pixel error, it's just wrong colored interpolation samples.
 
Old 06 June 2007   #4
Now I understand your problem, fortunately never happened to me...
Have you tried to increase grid size (from 2 to 1) or sample points (from 4 to 2) of the interpolation parameters?
Tonight I had some problems with a wooden ceiling with modeled staves (hope it's the right term) using interp. reflections; I tried with different combinations of parameters and in the end I had to render it without interp. reflections because it didn't work at all.
Some geometries struggle with interpolated reflections.
__________________
www.fabriziogambacorta.com
 
Old 06 June 2007   #5
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:14 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.