mia_material+gi

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  04 April 2007
mia_material+gi

Hi,
I have built a simple scene and all objects have mia_material assigned and I activated GI.The problem is that noting is rendered and in output window the message is "no photons stored".
However I manage to reneder the scene by plugin mia_material into the photon shader of the mia_material SG. Is it right what i am doing ?Is any other way to make mia_material to work with GI ?
Thanks.
 
  04 April 2007
Maybe the normals are pointing the wrong way... Maybe your scene is too small. If you create a sphere and use a directional light the 99% of the photon doesn't hit anithing so nothing is stored.
Hope it help!
 
  04 April 2007
thanks for reply,Gabba
I double check the normals before , the scene is modeled in world size,I,ve created a sphere but I use a spot light( quadratic decay) all the textures are gamma corected and I use Ctrl_buffer
anyway,.... is working only if I plug the material in the Photon Shader of MiaSG-
The other problem is that I've maped a wood texture on the floor shader (implicit for the photon shader since I use the same material) and now all my walls are brown-red from that texture.
How can I limit the affect of the floor and still having a physically accurate shader ?- because I can simply duplicate the mia material ,make it white and plug that in the photon shader - all my walls looks white... but I am sure that is something wrong proceeding like that....

Last edited by deltaindigo : 04 April 2007 at 08:26 PM.
 
  04 April 2007
Originally Posted by deltaindigo: ... is working only if I plug the material in the Photon Shader of MiaSG-
.
well, that's simply what you have to do, manually. from maya8.5 there's support for material phenomena so you could wrap the thing in a phen to having not to manually plug everytime your material connections. didn't tried myself.

Originally Posted by deltaindigo: ...
How can I limit the afect of the floor and still having a physically accurate shader.
on my part I have not this kind of problems. but you can plug another mia_material in the photon slot and there tweak something to get out what you have in mind. another solution could be to plug a ray switcher on top of the shader graph and there maybe supply a different texture(desat, so you'll get milder bleeding) only to the photon rays.

max
 
  07 July 2007
to stop your floor affecting the rest of your scene you can go down to the Mental Ray rollout of the shader, and uncheck derive from Maya. Then hit "take settings from maya" and reduce the reflectivity, diffuse and colour. These will not change the shader but will only reduce the energy photons have once they bounce off the floor.
__________________

Im not young enough to know everything...
LinkedIn
Flickr
Twitter


 
  07 July 2007
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:01 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.