Camera Matrix Problem

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 04 April 2007   #1
Camera Matrix Problem

In COFFEE, I'm using camera->GetMg()->GetV0() to get the global position of a camera object. When it is set as the scene camera, the position value doesn't update if the camera is moved via the viewport. The position value does however update if camera coordinates are changed directly in the AM or Coordinates Manager.

Any suggestions on how to overcome this problem?
 
Old 04 April 2007   #2
Afaik this is intentional. Editor Camera movements are handled differently due to it's own undo system. If i remember correctly expressions are not triggered by movements of the editor camera.
Cheers
Björn
__________________
- www.bonkers.de -
The views expressed on this post are my personal opinions and do not represent the views of my employer.
 
Old 04 April 2007   #3
That sounds logical, thanks for clarifying this.

I'll see whether I can find a workaround.
 
Old 04 April 2007   #4
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:13 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.