Mental Ray does not render Lens/FOV of Max camera, help!!!

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2007   #1
Mental Ray does not render Lens/FOV of Max camera, help!!!

(Max9)
Am I missing something. I am forced to use MR while I wait for Cebas to get their act together on the 64-bit version of FinalRender.

So I have a scene that I have tried different fov settings. But the render of MR always defaults to 35mm.

Am I supposed to set the lens somewhere else?

Ron R
 
Old 01 January 2007   #2
Hey Ron,

Not entirely sure I am understanding the queastion? MR takes
the FOV settings from the Max camera FOV unless you have
set up a camera or lens shader that would alter this behaviour.
Any help?

Regards
Bri
__________________
3Ds Max - Mental Ray - VRay - Training Modules

The MBM Blog

Vray Learning
 
Old 01 January 2007   #3
Ooops Edited because it double posted.

Bri
__________________
3Ds Max - Mental Ray - VRay - Training Modules

The MBM Blog

Vray Learning

Last edited by Brian-Bradley : 01 January 2007 at 10:47 PM.
 
Old 01 January 2007   #4
I don't have any special lens shaders

Here is a link to a problem file.
http://www.vdg3d.com/mr_scene.max

Here is a link to an image of what renders for me:
http://www.vdg3d.com/mr_test_render.jpg

Thanks for any help.
 
Old 01 January 2007   #5
Hi Ron,

Gotta admit I'm more confused than ever. The file renders
just fine, FOV is adjustable, output is adjustable.
Here is my render with a 20mm Lens with the output
rendered at 480x320. ?????

Bri
Attached Images
File Type: jpg temp.jpg (4.5 KB, 6 views)
__________________
3Ds Max - Mental Ray - VRay - Training Modules

The MBM Blog

Vray Learning
 
Old 01 January 2007   #6
So you agree?

So you agree with me. I get smae image as you with 20mm lens. But the viewport shows much more in the camera viewport. Does this happen if you create your own fresh MR scene? Anyone else have suggestions?
Attached Images
File Type: jpg Untitled-1.jpg (49.0 KB, 7 views)
 
Old 01 January 2007   #7
The camera was scaled, which can cause alot of problems. Select the camera and type $.scale = [1,1,1]

in the maxscript listener field, that should fix it.
 
Old 01 January 2007   #8
Ha, told you I wasn't quite getting the question.

Well spotted Chris, tis true you never want to scale a
paramentric object because once you do the 'parameter'
controls become essentially useless as they no longer
tell the truth. I set up a fresh camera and the Lens/Fov
setup works perfectly.

Ron, why do you have GI, Caustics and FG turned on
in the scene? With no lights or 'photon' using materials
you are wasting a lot of render time with no gain at the
moment?

Regards
Bri
__________________
3Ds Max - Mental Ray - VRay - Training Modules

The MBM Blog

Vray Learning
 
Old 01 January 2007   #9
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:55 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.