quadruped troubles

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2003   #1
quadruped troubles

Whats up guys...Does anyone have any good tips on rigging a wolf with bones in max5...Ive been having some trouble finding some good resources on rigging quadrupeds....Any help is much appreciated...Thanks
 
Old 02 February 2003   #2
maybe this thred might help you out
http://www.cgtalk.com/showthread.php?s=&threadid=12126
make sure to check out the jpg attachment by Eek , and he attached some sample files
 
Old 02 February 2003   #3
Thanks jnglemeat. There was some good stuff that set me in the right direction.

Is anyone familiar with setting up sliders in Max 5 or know where I can find some good tutorials on the subject.

Thanks
 
Old 02 February 2003   #4
Spline spine issues

Ok...I have all the legs rigged up nicely with a standard bone system with HI solvers. Everything in that department is fine...But when I tried to create a splineIK spine all seemed ok at first...But whenever I try to move the spine by itself or with helpers it takes about 30 seconds to update in my veiwport. I tried starting from scratch twice on the spine...Nothing I do seems to help...I wonder if anyone else has experinced this problem...Mabey its a bug..Im using an ATI 9000 128 with 1/2 gig of ram on a 2.4 gig sys..If anyone has any words of advice please help
 
Old 02 February 2003   #5
By the way...Im using Max 5.1
 
Old 02 February 2003   #6
mmm..

Hi Shade,

We get the same problem at work when we finish a complex rig,
i find if you reset and load up the scene again its fine. We work with radeons,gforce etc.

eek

p.s what kinda sliders do you want to setup?
__________________
Disclaimer: My opinions are not those of my employer.


 
Old 02 February 2003   #7
Ive reset many times over and even tried rebuilding the spline following the exact method they describe in the max tutorial on building and rigging the spine....Mabey it because im dealing with a quadraped? I tried loading it on my roomates computer and it lagged on his workstation so I dont think it is a hardware problem either...Is it possible to create an effecient spine using standard IK and HI Solvers? Thanks for your help eek...

ps...I ended up using spinners instead to constrain the roll of the paws...I found a useful section in the same tutorial...Thanks again to all who can help
 
Old 02 February 2003   #8
mmm..

What type of spine rig is it?, the the standard ik-spline with max 5 ? or something else. Ik spline in 5 is a bit flaky. At work i use around 3 main spine setups that are reliable and quick. At home i did an elephant rig with just 3 bones for the spine. ie.

chest
spine
hips

And this is generally what we use at work,but very good skinning on the model to accomodate squash twist. The slider idea is cool same as what i do. Basically i have manual controls for foot (pivot at ankle) and toe. But also have automated sliders to control heel lift, ball lift,rotate around toe etc. So you do it manually or automaticly when you want or mix.

There are so many ways of doing it.. recently ive been doing double rigs i.e constraining a rig on top of another to give me/fk ik controls. Its up you what you want? is you model a poly/patch nurbs. IF its poly/patch send it to me and i'll stick a setup in it if you want.

anyway here's the elefant walk:
(the green objects are what you move/rotate. its also a control model ie chopped up *easy to see weight etc)

http://www.geocities.com/nette_pictures/elephant.zip
right-click save target as:

eek
__________________
Disclaimer: My opinions are not those of my employer.


 
Old 02 February 2003   #9
Hey eek...That elephant animation was clean...Is it hard to use objects as bones. It seems much cleaner but I am not to familiar with this technique. Does it help when setting up for physique?...I was using splineIK so I guess im kinda glad to hear that it is buggy and it wasnt my setup. You can check up my setup here http://stu.aii.edu/~trc282/Wolf2B.zip Feel free to do whatever you want to it...Im trying to rig it for a clean run animation...I have controllers below the feet to control IK and spinners for rotation...Thanks again for all your help...
 
Old 02 February 2003   #10
By the way...I have everything hidden except the spline spine so just unhide all to veiw the rest...I havent set up the neck, head, or tail yet...
 
Old 02 February 2003   #11
hey..

Hey cool shaded,

I'll put a rig in it today, how do you want the spine: simple 3 bones or complex 6? both will use the same contollers easy to use. I'll do a chopped controll version but skin both.So you can work with a low poly version in the viewport and render the high poly.

eek
__________________
Disclaimer: My opinions are not those of my employer.


 
Old 02 February 2003   #12
good looking out eek. I think I better go with the complex 6 if it isnt to much trouble because I want to do a run cycle that is somewhat exagerated yet realistic, but if you think I can pull this off naturally with a 3 bone spine than just go ahead with that...Thanks again man...Your hookin me up with some serious knowledge...
 
Old 02 February 2003   #13
so far..

nearly there shade..

Rigs all in there, might change the back feet. Its using a control mesh in the viewport(blue) you control it with the green/red and white controls. The red shapes control entire part ie; hips/chest/head and chest head. The green controls control there specific part i.e hips, chest, head, ankle. The white circles control anke twist so rotate them in Z/locally. The green bones can be controlled.

http://www.geocities.com/nette_pictures/Wolf2f.zip
right-click and save target as:

i'll skin the rig sometime just busy at the minute with work.

eek
__________________
Disclaimer: My opinions are not those of my employer.


 
Old 03 March 2003   #14
Thanks

Thanks eek for the demo...I can feel you on the busy schededual. Im in the same situation...You defenitly cleared some things up for me...How exactly did you make your control Mesh?...Did you just add IK to it once it was done?...Thanks again for all your help.....
 
Old 01 January 2006   #15
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:09 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.