How to disable anti-aliasing completely?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  05 May 2006
How to disable anti-aliasing completely?

As the title says, how do I disable anti-aliasing completely. In the render options, I can only set it to "Low Quality", there seems to be no "Disable Anti-aliasing" option. Low Quality gives me pixel smoothing; I don't want none of that :/

Is it possible?
 
  05 May 2006
If you're using Mental Ray then give both the Min Sample Level and Max Sample Level a value of 0.
__________________
Lazhar Rekik
 
  05 May 2006
I haven't tested it but the folowing sounds plausible:

It may sound weird but if you select highest quality for edge antialiasing, a few options become available, like Multi pixel filtering.Select a box filter and for the x and y width choose 1 as value.
If it is still smoothing the pixels you might want to play with the RGB threshold value (also 1 I guess or 0 don't know for sure )
Let me know if it worked.

Cheers

TomD
 
  05 May 2006
I'm using Maya software renderer :/
 
  05 May 2006
use a mosaic/pixelize filter in a compositing program. it's easier!
__________________
_________________________
not enough mana to cast spell
rendering aborted
 
  05 May 2006
I doubt that will give me the results I want. I have a lamp shader with different colors. I want no transition whatsoever between these colors. However, the anti-aliasing gives me color smoothing....
 
  05 May 2006
Originally Posted by TomD: If it is still smoothing the pixels you might want to play with the RGB threshold value (also 1 I guess or 0 don't know for sure )
Let me know if it worked.


The sampling threshold is for adaptive anti-aliasing and has absolutely no effect if both min and max sampling are set to the same value.

What lazzhar suggested is correct. Setting both values to 0 will sample every pixel exactly once.
__________________

 
  05 May 2006
This is directly from Maya help
Quote: Low Quality
Fastest anti-aliasing setting. For each rendered pixel, two points are analyzed and used to determine which part of the object is visible, producing low quality edge anti-aliasing.
It seems that one can't go any lower than that with the Maya software renderer. But here's a workaround, in the Render Options > Color/Compositing section you can uncheck Premultiply which will eliminate completely the antialiasing for the color only but not the alpha. If you want alpha too, just render again and assign to your objects completely white surface shader and use the resulting image for an alpha channel
 
  05 May 2006
Originally Posted by Emil3d: uncheck Premultiply which will eliminate completely the antialiasing for the color
this is not what premultiply does.

I've needed to turn off anti-aliasing as well and couldn't find a way in Maya software. In mental ray you have to set the samples to 0, and for some reason turn scanline to "rapid" in the raytracing section. That apparently disables multi-pixel filter.
 
  05 May 2006
Originally Posted by pgraham: this is not what premultiply does...
I tried it and this is exactly what it does if you render the object against a backtround. I suggested this as a workaround of course. Quote from Maya Help:
Quote: ...If on, Maya renders objects so that they are not anti-aliased against the background. For example, a pixel on the edge of an object is not mixed with the background color. (In TIFF terms, Maya generates unassociated alpha.) If off, Maya anti-aliases objects against the background. Premultiply is off by default

Last edited by Emil3d : 05 May 2006 at 06:14 PM.
 
  05 May 2006
What about rendering with Maya Hardware? It sometimes give the same results as Mayasoft and you can turn off the AA easly there.
__________________
Lazhar Rekik
 
  05 May 2006
Originally Posted by Zeicon: I have a lamp shader with different colors. I want no transition whatsoever between these colors. However, the anti-aliasing gives me color smoothing....

For that you could turn the resolution up to twice the width and twice the height, render, then scale down using nearest neighbor.

-jeremy
__________________
Jeremy Birn
Author, Digital Lighting & Rendering, 3rd Edition
 
  05 May 2006
So it's not possible to turn off anti-aliasing with Maya software renderer? I find that really weird... :/
 
  05 May 2006
Originally Posted by Emil3d: If on, Maya renders objects so that they are not anti-aliased against the background
This means that samples of the background are not averaged in to the pixel color, and it only makes a difference on the edge of the alpha. All pixels are still multisampled and averaged. Thus the varying colors of the lamp will not be aliased, only the boundary will appear jagged.
Originally Posted by jeremybirn: For that you could turn the resolution up to twice the width and twice the height, render, then scale down using nearest neighbor
That will look "more" aliased but you're sampling nearest neighbors from a set of already antialiased pixels.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:38 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.