Unwrap UVW Issue driving me crazy!

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Display Modes
  02 February 2006
Unwrap UVW Issue driving me crazy!

Ok the usuall problem, i keep posting in one form or another and noone ever seems to know whats going on...

Anyway this scenario is a little different.

Ok the problem stems from changin the map channel in the unwrap modifier, after changing the map channel the modifier seem to not respond to my maxscript...

Ok heres my code....


 myobj = $  -- just for testing...
 
 modPanel.addModToSelection (Unwrap_UVW ()) ui:on
 myObj.modifiers[#unwrap_uvw].unwrap.setMapChannel 2 --script goes bung after here!
 subobjectLevel = 1					
 myObj.modifiers[#unwrap_uvw].unwrap.edit ()
 myObj.modifiers[#unwrap_uvw].unwrap5.setSelectedGeomVerts mySelection --this doesnt work when not on map channel 1!!! WHY?!
 myObj.modifiers[#unwrap_uvw].unwrap.moveX 0
 


There must either be serious bugs with the unwrap modifier or im doing something so stupid i cannot figure it out :|

Any help appreciated.

Thanks
Bronson


EDIT: Odd, seems to work in a blank script, could it be something such as a rollout?
__________________


Last edited by Gibbz : 02 February 2006 at 09:51 AM.
 
  02 February 2006
Ok this is even more crazy.

If i use either Try() or undo() or use them together, the script does not work. Any ideas why this is? Any work arounds?


try
(
	undo on
	(

			subobjectLevel = 0
			modPanel.addModToSelection (Unwrap_UVW ()) ui:on
			$.modifiers[#unwrap_uvw].unwrap.setMapChannel 2
			subobjectLevel = 1					
			$.modifiers[#unwrap_uvw].unwrap.edit ()
			$.modifiers[#unwrap_uvw].unwrap5.setSelectedGeomVerts #{1..15}
			$.modifiers[#unwrap_uvw].unwrap2.syncTVSelection() --sweet fix!
			$.modifiers[#unwrap_uvw].unwrap.moveX 0	

	)
)
catch (format "Align U 0 Error: % \n" (getCurrentException()))
__________________

 
  02 February 2006
Just a thought, stab in the dark if you will, but do you need to turn on map support and adding some map verts for channel 2 before adding the modifier?


 mesh/polyop.setMapSupport $ 2 true
 mesh/polyop.setNumMapVerts $ ((GetTriMeshFaceCount $)[1]*3)
 
 
  02 February 2006
I already have channel 2 mapping data. Ill give it a try with vertex color chanel see if that has the same probem
__________________

 
  02 February 2006
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:31 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.