Adding Polys to Imported Model

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2006   #1
Adding Polys to Imported Model

Okay, so I have a two part question. I'm new to zBrush (2.0) but not to 3d Max 7, which is what I'm using to create my basic, undetailed mesh. My first problem is that when I try to import my model into zBrush as an .obj file I get this weird, jumbled mess of polygons. After trying a couple different things it still imports the same. So I tried the other file zBrush recognizes, a .dxf. The problem is my model had more polys then a .dxf could contain. After knocking off enough polys it worked and imported into zBrush as a .dxf just fine. The only problem was it had too few polys to allow me to do much with it in zBrush. I've played around in zBrush and added more polys to spheres by using the Initialize modifier under the tools menu. But I just can't add polys to my model the same way for some reason. The initialize modifier isnt there... SO since I can't add more polys my model looks bad and the details I try to add make it even worse. Here's what I need to know:

1. Why does my model become a jumbled mass of polys when I export as an .obj file? Is it just an issue with 3d Max 7?

2. Why can't I add more polys to my model when I import as a .dxf??


Sorry, if some of these questions have been answered somewhere else that I don't know of. If anybody could help me out I'd really appreciate it!!
__________________
"I've seen things you people wouldn't believe. Attack ships on fire off the shoulder of Orion. I watched C-beams glitter in the dark near the Tannhauser gate. All those moments will be lost in time, like tears in rain. Time to die." -Roy Batty
 
Old 02 February 2006   #2
Not 100 percent sure about your jumble mesh problem try In max when you export out as an .obj turn up the number of digits slider to 6, will at least fix uv problems. What are your settings for your export on obj? are all your verts welded?

In zbrush under tool - geometry - divide. This is where you divide your mesh and work with multiple sub division levels of editing. This will increase your poly count. The higher you divide it the more detail you can get.

The initialize is only for primitive zbrush objects not imported meshes or poly3d meshes.

Last edited by eblondin : 02 February 2006 at 09:21 PM.
 
Old 02 February 2006   #3
Thank you so much!!
__________________
"I've seen things you people wouldn't believe. Attack ships on fire off the shoulder of Orion. I watched C-beams glitter in the dark near the Tannhauser gate. All those moments will be lost in time, like tears in rain. Time to die." -Roy Batty
 
Old 02 February 2006   #4
Did this work out for you?
 
Old 02 February 2006   #5
I found the subdivide modifier you mentioned and was able to at least fix that problem. Unfortunately I still have to export as a .dxf, which limits me to around 32,000 polys when exporting. I'm trying out different work flows with zBrush and I'd heard that by modeling an object in Max, laying out the UVs, adding several iterations of meshsmooth for extra polys and then importing into zBrush you can work freely on your model without ever sub dividing in zBrush itself. From there you can add whatever details you want, add textures freely, and then import the piece back into Max and simply morth your original using the newly imported zBrushed model as a reference. That technique appealed to me because I'd prefer not to do everything in Zbrush you know?

Unfortunately, I still can't export as an .odj. I changed the digits to six, exported,then imported into zBrush but still got a jumbled mess like this:
http://i43.photobucket.com/albums/e...yNewo2/mess.jpg

Here are the options I used when exporting from Max as an .obj:
http://i43.photobucket.com/albums/e.../screenshot.jpg

Using .dxf files sucks because they don't allow many polys when exporting, and I can't sub-divide or I won't be able to morph from it afterwards. An .obj would give me a higher poly limit but that still doesn't work. So... maybe I'm going about this the wrong way and making way too much trouble for myself. I'd still like to do the basic modeling work in Max until I'm used to doing so in Zbrush using zSpheres. I'm more familar with Max and I'd like to start the model there, add the details and textures in ZBrush, and then finish it all up in Max. Any better ideas?
__________________
"I've seen things you people wouldn't believe. Attack ships on fire off the shoulder of Orion. I watched C-beams glitter in the dark near the Tannhauser gate. All those moments will be lost in time, like tears in rain. Time to die." -Roy Batty
 
Old 02 February 2006   #6
On your .obj export from max turn off the bottom two check boxes and try upping your number of digits to 12

I think your workflow is fine. You will have fewer problems trying to import/export back and forth between zbrush and max if you start in max so thatís not a bad idea. I have seen max handle upwards of 4 million polys in the viewport with turbo smooth and a decent machine so if you can get the level of detail/complexity you need from that and donít have to subdivide in zbrush thatís fine.

I am guessing that you dont want to create a normal or displacement map. because if you donít subdivide it in zbrush, you wont be able to, in zbrush anyway.

It seems like your opening the door for a lot more computer lags and crashes if you try to keep all your high rez detail straight on the geometry and not in a displacement/bump or normal map. Just saying, I can foresee problems with that. Anyway, good luck!

It is almost always better to have a low rez mesh for many different reasons. Among which are just file size load time and ability to make quick changes quickly with as few polys as possible. Not to mention rigging and animating.

Last edited by eblondin : 02 February 2006 at 08:52 PM.
 
Old 02 February 2006   #7
Thanks man, that fixed the problem! So what do you use ZBrush for and what's your work flow? What works best for you?
__________________
"I've seen things you people wouldn't believe. Attack ships on fire off the shoulder of Orion. I watched C-beams glitter in the dark near the Tannhauser gate. All those moments will be lost in time, like tears in rain. Time to die." -Roy Batty
 
Old 02 February 2006   #8
This is my latest work

zombie

I did every part of that model inside zbrush except for the unwrap.

I love it for everything that it does, modeling, texturing, rendering. Creating displacement, bump, normal maps.

I am mainly a character guy so that is what i mainly use it for.

My workflow is normally

  • zspheres to make base mesh,
  • Base mesh out to max or maya unwrap/fix edges.
  • base mesh back in sub divdie and go to town,
  • texture, bump normal all that goodness
  • Then back out to maya or max for low rez game fun!
 
Old 02 February 2006   #9
That's cool man, that's some really nice texturing work on the zombie.... damn. Well, thanks for answering my questions man! You've really helped me out!
__________________
"I've seen things you people wouldn't believe. Attack ships on fire off the shoulder of Orion. I watched C-beams glitter in the dark near the Tannhauser gate. All those moments will be lost in time, like tears in rain. Time to die." -Roy Batty
 
Old 02 February 2006   #10
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:07 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.