Finding shared edge in uvw unwrap?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2005   #1
Finding shared edge in uvw unwrap?

I have 2 faces i need to find the shared edges(the ones which show up as blue in the uvw unwrap dialog) in the uvw editor. Is there any way to find the shared uvw edges(not the edge of the mesh as this seems to be difrent) of the 2 faces?

I have an idea, which seems a little dodgey...

-Get 2 faces
-select the shared mesh edge
-convert to unwrap to find the 2 uvw edjes on current selection
$.modifiers[#unwrap_uvw].unwrap2.getselectedEdges()

-select faces and get array of edges
-compare faces array and find the shared edges

Does that sound like it would work?
__________________

 
Old 11 November 2005   #2
ok so far was having good luck, now not shure if this is a bug again or something im doing wrong....

Ok im trying to select an edge


 			myEdgeShared = 7
  			myObj.modifiers[#unwrap_uvw].unwrap5.setSelectedGeomEdges #{}
 		    myObj.modifiers[#unwrap_uvw].unwrap5.setSelectedGeomEdges #{myEdgeShared}
 			mySharedUVEdge = (myObj.modifiers[#unwrap_uvw].unwrap2.getselectedEdges()) as array
 


no basically what SHOULD happen, it clears selection, selects edge 7.
And final line should get the shared UV edge.

Now the problem is occuring between the last 2 lines. It selected the edge in the viewport, but it

basic output goes something like this

line 1, myshared edge = 7
line 2 and 3, OK
line 4 #(21, 22, 23, 24)

This should only show the 2 shared edges.

Ive also noticed if i then go back to facemode in unwrap uvw then back to edge mode, all the edges in the array #(21, 22, 23, 24) are selected.

Any ideas why this is?
__________________

 
Old 11 November 2005   #3
I can't test this because I have not max8 but the command unwrap5.setSelectedGeomEdges seems to select the geometry edges and not the uvw edges as you would like.

I think you did not define the right relationship between geom edges and map edges.
 
Old 11 November 2005   #4
Originally Posted by Gibbz: Ive also noticed if i then go back to facemode in unwrap uvw then back to edge mode, all the edges in the array #(21, 22, 23, 24) are selected.

Any ideas why this is?


You have to change the mode to view the result because the interface is not updated.
 
Old 11 November 2005   #5
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:38 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.