SSS multiple surface prob

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  10 October 2005
Angry SSS multiple surface prob

Hey,

Ive got an object i need to combine SSS surface with other surfaces (lamberts, phongs ect). Now, when i do this this go a bit weird. See attached images. The first is my SSS surface, works fine. Now add another surface, ah. Ive heard that setting my light linking mode to 2 fixes this, but see the third render and it just doesnt look right, the colours all wrong and there is not specular.

Any ideas, i know this is a common prob.

Cheers,

Nick D
www.thepra.com.au
Attached Images
File Type: jpg 1.jpg (16.9 KB, 117 views)
File Type: jpg 2.jpg (8.8 KB, 61 views)
File Type: jpg 3.jpg (9.5 KB, 76 views)
 
  10 October 2005
as far as i know, misss shader won't work if you're trying to attach it to a group of polys, while using a different shader on the rest of the object..

i believe it's an all-or-nothing kind of thing.

others here may be able to explain this in more wicked technical detail.. particularly MasterZap, the creator himself.
 
  10 October 2005
Maybe you should try to use two shaders, one lambert for example, and one miSSS material and layer them with mix8Layer.
Don't forget to put the lightmap in the mix8Layer SG.
 
  10 October 2005
I've used sss attached to polys successfully before.

Did you try attaching the lambert first to a group of polys and then your sss to the other group of polys?
 
  10 October 2005
Hey,

ive never used Mix8 before, can you give some more info on what it does? I basicly challange anyone to do what i did in the test i did and make it work!

Cheers,

Nick D
www.thepra.com.au
 
  10 October 2005
try connecting all your ligts to the shader and the lightmap thingy
 
  10 October 2005
osaires s right,

if you connect your lights to your sss shader node and lightmap node it works.
 
  10 October 2005
miSSS works with groups of polys

In the misss shader..turn the lightmode to 2 and also in the lightmap.

Marlboro Man
__________________
" I LOVE MODO 3 "
 
  11 November 2005
In case you guys are not aware, our beloved Lightmap trick is BROKEN in Max 8. If you pick a custom lightmap SSS will no longer work. I've posted this here and on the Max webboard but nobody seems to care. Pretty sad since this means I will have to stick with Max7 until this is fixed.

:(

-m
 
  06 June 2006
Talking

...max8...ehemjaja....max7......yeah of Course..!! I know dude... Software is Software, isnīt it... =)) Ohhh...somebody was sitting to long in front of a computer.... get orientation where you are... *gg*
__________________
" GEDULD IST FUER MEMMEN "
 
  06 June 2006
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright Đ2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:22 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.