Zbrush Displacement Map Problem

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Search this Thread Display Modes
Old 03 March 2005   #1
Zbrush Displacement Map Problem


I recently bought Zbrush2 and now i try to use the Displacement Map (its from Zbrush Central) on the Model( also from Zbrush Central). But there are some errors and i dunno what causes them....
Please help me cause I want to go on and work with the amazing Zbrush Program. Thank you.

...the funny thing is that some areas are correctly displayed (the neck) and some are not..
Old 03 March 2005   #2
Hi Grashupfa,

Looks like you need to flip the displacement map vertically. Try that and see how you go.


Old 03 March 2005   #3

Thx for ur reply...but that didn't help ...well, i attached the image rendered with the vertical-flipped Map....
Any other suggestions that might work?
Old 03 March 2005   #4
Nobody knows a solution for my problem?
Maybe any tutorials which could help me?
How do you guys do that`? I mean, if u want to go from maya to zbrush and vice-versa?
Please help me, i really like Zbrush but if i can't combine it with Maya its useless for me.
Old 03 March 2005   #5
looks like you have to keeping flipping stuff, your uvs aren't matching up
Old 03 March 2005   #6
hm...well, i flipped the map all directions but it doesn't work..well, i tried my best...thx for help, i'll keep searching for a good tutorial until i figure it out
Old 04 April 2005   #7
no matter which tutorial i make, i always get those 2 error messages in my mental ray output window:

RCFG 0.5 warn 542002: angle between normal and geometry normal more than 90 degrees
SURF 0.2 warn 392010: surface "ZBrushPolyMesh3D2Shape", displacement shader returned values up to 0.338861, clipped to 0.251767

I dunno what it could mean, but maybe u guys know? Please help me
Old 04 April 2005   #8
post a pic of ur settings for the subD head approximation editor for MR
that is statistically impossible
Old 04 April 2005   #9
yep... i attached them (both, subd and displacement)

i tried many settings for those windows...dunno if there is the problem...
Old 04 April 2005   #10
To me it looks like your uvs some how got out of whack. I tried it here and it worked perfectly. You may want to try and re download the sample and try with a fresh one. Another thing that you need to do is make shure that you set it to rgb instead of gray but that shouldnt cause the problems that you are having.
Old 04 April 2005   #11
Well...i tried it another time...and it didn't work...but i'll post an exact workflow what i do when i am at home... ty for ur replies till now
Old 04 April 2005   #12
1. Download File
2. open tiff file in photoshop (color managment off)
a. switch image to rgb-mode
b. save it
3. Open maya
4. import the head(mesh)
5. go to hypershade, create a new lambert, in its displacement map section i added a file note
6. include the tiff map(rgb) in the file note...set alpha gain to 12 and alpha offset to -6
7. assign the material to the mesh
8. add a mental ray displacement approximation (settings shown above)
9. add a mental ray subdivision approximation (settings shown above)
10. Render Mesh in Mental ray (result -> attached)

hm...i did it exactly as i described above...maybe i have missed a step? Is there something wrong? Please help-> now it should be no problem for u pro's
Old 04 April 2005   #13
u also need to change the image to 8 bit in PS after u turn it into rgb image.
your alpha gain is way too high.
try 1 and -.5 or 2 and -1
select the subD object and turn off "feature disp mode" in the shape node of the object[listed in the displacement pull down menu]
u dont "need" to add the MR approximators for it to work; try without
that is statistically impossible
Old 04 April 2005   #14
hm..thx for ur reply ...but i also tried ur suggestions and they didn't work either....what else can i do? it could be an uv-problem, but how do i get it? what can i do against that? could it also be an image-converting problem?...

Well...i think some of the areas are correctly mapped (but i dunno exactly, never had the final result) What do u say? (green line should be okay, red are problem areas)

Please could u guys describe what exactly u did that the image file was suitable? Here is the link: test file

Last edited by Grashupfa : 04 April 2005 at 02:15 PM.
Old 04 April 2005   #15
Acually you need to keep it 16 bit or else you will loose a lot of detail in your map (verry important). It looks to me that you didn't flip your map vertically. I know that you mentioned that you did in a earlier post but why i say that is because it looks like the part that should be mapped to the back of the head is acually on the neck. Just incase you didnt do it all you need to do is go to photoshop and go to Image>Rotate Canvas>Flip Vertical. Let me know if that works.
Thread Closed share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 09:12 AM.

Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.