Exporting to .STL files

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  03 March 2005
Exporting to .STL files

Hi, i begin to model with modo, and my friend who is a designer ask me to convert/export a modo file into STL, so i think it would be done with LW but not, but i find a script on www.vertexmonkey.com in I/O File Scripts, written in perl by Dion Burgoyne, so i download it
and put it into modo.exe directory. Then i bind my CTRL+ALT+S to @exportSTL.pl

when i press my combo (CTRL+ALT+S) to export my model to .stl modo going to error with
a line of script (39):

From Event Log:
Scripts || Error || Search pattern not terminated at (eval 1) line 39.
Commands || Error || script.implicit failed

the line 39 of Perl file is:
my @c = lxq("query layerservice vert.pos ? $vertlist[2]");

I think i mistake something, but i try also with Headphones.lwo model, and i try to frozen it with Lightwave cause i dont know how to do this with modo, and then re-import the model .lwo in modo, but the error is the same, then i read that i've to convert my model to triangles before exporting, but i dont know how to do that.. :(

i'm really newbie of 3d modeling and export/import 3d files too
so if anyone can help me, i'm very confused...

i only want to export a .lwo file to .stl for a prototype machine.
how can i do with modo application?

thank you..

brankojr
 
  03 March 2005
If you have Lightwave then why not use Sean Hyde Moyer's STL export Lscript. I too have problems with the Modo STL script but I'm sure that Dion will emerge after his lunch with a solution.
 
  03 March 2005
really thx noiseboy!
i find that script and i converted the .lwo model,
now i can try to send that to the prototype machine's experts
and then they will say me if that will be ok..

i hope Dion will fix the stl export script for modo!

bye, thx again..
 
  03 March 2005
I was hoping that you could cut and paste the entire script into a window here, internally we believe that it's getting corrupted somehow invalid endlines etc... As the script compiles and runs on every system that we have here...

One item of note, when working on the MAC, you MUST put the file extension after the name of the file, if not the Mac may become unstable. Sneaky little bug...

so save all files as

filename.STL

I should have another version of the script soon
__________________
QA Manager
Luxology, LLC
 
  03 March 2005
what Dion said, plus you must remove anything like 2 vertex polys as well as triple the quad polys to get the save dialog to come up ( in my testing anyway)
 
  03 March 2005
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:38 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.