Connecting locator to texture?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 10 October 2004   #1
Connecting locator to texture?

I've got a character with a fairly flat eye, and I was setting up the eye with a locator. I was going to just connect the texture on the eye to a locator using the connection editor, but I can't seem to find what I've got to do. Basically, I want a locator to drive the placement of a simple ramp on the surface of the eye. I tried looking in the driven key menu, but I can't seem to find what I need there, either.

Anyone have any suggestions?
 
Old 10 October 2004   #2
I've never had to solve this problem before, but if you are projecting the texture onto the surface of the eye, then you could just connect the texture projection node to the locator ... couldn't you? If you point constrained the projection node to the locator with maintain offset toggled on for the constraint operation, then you should be able to move the locator and the projected texture should move with it.

at least it works in my head ...
__________________
---
DISCLAIMER: This message represents my own opinion and does not reflect in any way the opinion of my employer .
 
Old 10 October 2004   #3
Ahh, okay. The texture on the eye I'm using wasn't projected, actually. I consulted a friend of mine today, and he suggested using a script and showed me how to set that up, but he also recommended using a driven key (which I had tried before). The way I had tried to load the place2dtexture node in the driven box was just totally wrong before, but with my friend's help, I got it loaded.

So basically, I keyed the offset U and V attributes to correspond with the translate X and Y on the locators. If you can't seem to get the place2dtexture node to load into the driven key window, you can go to the attribute editor, go to the offset attribute boxes, and right-click in the box. There's a "set driven key" option there, and it'll load that in the driven box. All you have to do after that is load the locator in the driver window, and key it. So, now it works.

Thanks for your help, though. I don't know, maybe your solution and mine will be a handy reference or something now.
__________________
Parts of this game may be considered violent or cruel.
 
Old 01 January 2006   #4
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:38 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.