How to make my animation run at twice the original speed?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2004   #1
How to make my animation run at twice the original speed?

How to make my animation run at twice the original speed in shake?

I noticed that one of my shots would look quite better if it ran at twice the original speed. How can i tell shake to make my animation from 12 seconds to 6?

I read that it needs to be done with a script, but i didnt understand the manual on how to do it.

*Yes im quite stupid when it comes to program a script... even a simple one 9_9*
__________________
'If you wait until everything is perfect before you take that first step, you will stand in place forever.'
 
Old 06 June 2004   #2
To do a straight speed increase like this, in your FileIn node, set the Increment to 2 (this is how many frames of the sequence it increments every frame of the timeline)

The other option is the ReTiming section (under the Timing tab). Set the reTiming parameter to "speed" and the "speed" parameter to 2...
__________________
Hugh Macdonald
nvizible
 
Old 06 June 2004   #3
3rd idea would be using the timeX at the very end of your script. in there you can keyframe the timing very well

tip: use that node as well, if you e.g. have to time offset quickshape animation and so on..

cheers

alexx
__________________
"A computer program does what you tell it to do, not what you want it to do." Greer's Third Law.
 
Old 06 June 2004   #4
That's certainly another valid option...

There is one huge gotcha with the TimeX node that you've got to be REALLY careful about...

If you have a TimeX node in your script, everything above that node will be affected by it at the root.

So the following script (for getting part of the previous frame and layering it over the sequence) will not work:



This is because the TimeX node will affect the FileIn node on both branches. If you want to do something like this, then you have to have two FileIn nodes

Edit: Interesting! CGTalk's background is exactly the same colour as Shake's!
__________________
Hugh Macdonald
nvizible
 
Old 06 June 2004   #5
damn this is sooo beyond me
__________________
I am not alone
 
Old 06 June 2004   #6
I found this one out the hard way... after getting VERY confused when it wasn't working....
__________________
Hugh Macdonald
nvizible
 
Old 06 June 2004   #7
same here..
i tried to create a "smarter" average or ghosting script than the one that comes with shake.. but of course i was not able to succeed

cheers

alexx
__________________
"A computer program does what you tell it to do, not what you want it to do." Greer's Third Law.
 
Old 06 June 2004   #8
Tanks for the replyes

im quite confused about TimeX, how should i set the speed there?

I tryed the Retiming and it works quite well, but i have to apply the increment to every clip, and since i have many different nodes i lost the consistency of the shot. Is there a way to set a node at the end that makes my composition stay together? i know it might be with TimeX... but how thoes that work?

Another question.. if i change the Increment (the one on the bottom between the "Current" frame and the play buttons... the one called "Inc" if i change that it affects the final speed or it only affects the visualisation speed?
__________________
'If you wait until everything is perfect before you take that first step, you will stand in place forever.'
 
Old 06 June 2004   #9
Ahh - to do that, you will want a TimeX node right at the end with the time parameter set to "time*2"

This means that when the FileOut node asks for frame 1, it will actually be given frame 2, and when it asks for frame 2, it will actually be given frame 4, etc...
__________________
Hugh Macdonald
nvizible
 
Old 07 July 2004   #10
timex concatinates up the tree. You dont have to add two fileins up the tree, just break the concatination by placing a node in the tree that will interrupt this. Try using a blur, but make the vaule for theblur 0 so it wont do anything. This should fix your problems.

Try reading up on the manual about concatination
 
Old 01 January 2006   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:58 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.