nParticles with instancer and random scale

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  04 April 2018
nParticles with instancer and random scale

I have a scene where I have a cup that i'm trying to fill with 4 different kinds of berries.
I have the cup filling and the berries are running through the instancer just fine, problem i have iw that i cant randomize the scale of the berries.
if i randomize the scale then the collision radii dont sync up, and if I randomize the the radius, then the geometry collides with gaps between them.

I have tried a few different ways, but somewhere i seem to be missing something.
anyone have more ideas on what I could attempt
 
  04 April 2018
Hi,

what Maya version are you using? This was a bug once upon a time that was fixed and only the collision thickness display was wrong. But since 2017 this should also be fixed.

Cheers
 
  04 April 2018
working in Maya 2018
 
  04 April 2018
In what way are you randomizing the radii? Are you using the internal radius ramp?
 
  04 April 2018
I dont think so, it doesnt seem to be hooked up anywhere.

i was just trying to use a "=rand (.4, 1);"
 
  04 April 2018
something isnt wired up properly, if i use the radius ramp it does nothing
 
  04 April 2018
Is the internalRadiusRamp connected to the radiusPP attribute? It should connect automatically if radiusPP is not used within an expression and you change settings on the radius ramp.
 
  04 April 2018
it did create the link when i set the ramp to normalised age, but it still isnt changing the size
 
  04 April 2018
ok, so i can get the particle shape to randomize, but if i turn on spheres (under shading so i can see the collision particles) my mesh objects from the instancer always seem to be smaller than the collision sphere

Last edited by Snake Eyess : 04 April 2018 at 05:18 PM.
 
  04 April 2018
You should be able to simply scale your objects until they match the particle radius.
 
  04 April 2018
well, the scale is random, so if i change the scale of the objects, I will still have the same issue where some will be bigger and others smaller than the collision radius
 
  04 April 2018
setting it to scale using the age makes the particles/objects change through the whole animation, i need it to randomize scale on creation only
 
  04 April 2018
The reason your instances don't sync up with particle radius is because those attribute aren't connected by default. Instance size is controlled by a scale attribute on the Instancer (Geometry Replacement) section. You can connect radiusPP to the scale of the instanced geo. Should solve your issue.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:50 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.