Maya stalls when selecting objects

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Unhappy Maya stalls when selecting objects

Hey guys!

I have a rather deep scene-hierarchy and when I select objects, or manipulate an object maya sometimes stalls for several seconds, showing me the spinning-circle-cursor.
My scene was merged together from two other scenes, each of which performs fine or with much shorter stalls than the merged one.

A colleague suggested that it happens because maya evaluates the dag-path to update the transform of objects in the scene.

The strange this that it even happens when I select the very root of the hierarchy.
Does it evaluate/update all children then, or why would it take so long?

Has anyone had this as well and knows how to fix?
__________________
Working with 3dsmax 2012 & maya 2014 on Win 7 64bit
 
Old 02 February 2013   #2
In older versions around 2011, this was partly due to the Attribute Editor as well. Try hiding that and seeing if it helps but I think it was resolved in 2012/2013
 
Old 02 February 2013   #3
Does it happen if the viewport is not visible?
Or if selection highlighting is turned off?
I sometimes have crazy lag on selecting detailed objects if it is visible in the viewport...I've sped things up when possible by working without viewport or selection highlighting. A shot in the dark...but maybe it will help.
~Ben
 
Old 02 February 2013   #4
Thanks for the replies!

I tried both those things, but none of them improved the stalling. :(
__________________
Working with 3dsmax 2012 & maya 2014 on Win 7 64bit
 
Old 02 February 2013   #5
I've started the thread for the same reason here:

http://forums.cgsociety.org/showthr...p?f=7&t=1093976

Are you selecting objects or instanced objects like me?

It looks like it starts happening after deleting render layers.


Als
__________________
"No Bucks, NO Buck Rogers!"

VFX rule no. 387
# Just redo it!

 
Old 02 February 2013   #6
It seems like I managed to resolve it.

I has quite a few wrap deformers with exclusive bind disabled in my scene and although they were hidden, they must have contributed to the stalls. I enabled exclusive bind on all of them and the deformation is not only much faster, but the stalls are almost gone now and significantly shorter.

Als, it seems that, under some circumstances, something that is a little slow un the scene, can become 10-times as slow or more. Maybe you can find the bottleneck in maya 2012 that makes your scene so slow in 2013.
__________________
Working with 3dsmax 2012 & maya 2014 on Win 7 64bit
 
Old 02 February 2013   #7
I've tried the same scene in 2011 and 2012, after taking out the -ch thing.
And there it works just fine. It's instances and 2013 just doesn't like them?


Als
__________________
"No Bucks, NO Buck Rogers!"

VFX rule no. 387
# Just redo it!

 
Old 02 February 2013   #8
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:36 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.