Viewport problem in Cinema4d R14

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2013
Viewport problem in Cinema4d R14

I've just installed R14 and upgraded to latest version 14.034. I'm experiencing terrible viewport slowdown, I read something on the internet about disabling highlighting outlines and that helped quite a bit, but absolutely not as fast as in R11.5.
I'm working on an first generation 8core macpro, ATI radeon X1900 512MB driver EFI: 01.00.202, OSX 10.7.4
Any help will be much appreciated
 
  02 February 2013
A few times since r13 (and seemingly random at that) I've experienced a weird, terrible slow-down in the editor on relatively lightweight scenes, and found that for whatever reason, completely turning off all HUD elements made the editor glide again.

It sucked, because I use the HUD all the time, but maybe try turning off all HUD elements, even the defaults, like the camera projection.

Although, I don't recall experiencing this issue for a while, I can't remember if it persisted in r14.

Another problem was a temporary dual monitor set up I had. Didn't narrow that down, but it was a cheap monitor and I had to use an adapter to plug it in, so maybe the card choked on that. It was mostly unusable for anything but a few simple palettes and whatnot.

I'm on a MacPro 12-core, OSX Mountain Lion, ATI Radeon HD 5870.

Anyhow, all seems great now, hope you figure it out.
__________________
I'm a gun for hire... My work & gallery.
 
  02 February 2013
Probably the main thing is to check the enhanced opengl setting (though i'd be surprised if it worked with something as old as the x1900) From version to version, what the enhanced opengl mode does, and what the base opengl modes do, has changed quite a bit depending on what gfx card you have installed.

In older versions of c4d, regular ogl used older faster techniques such as per-poly shading and you had to enable enhanced ogl to get proper shading. With newer versions, the baseline has shifted, so now the regular ogl uses per-pixel shading and the enhanced mode gives you even more bells and whistles on top.

In short, try turning enhanced opengl on or off. Also check you havent enabled opengl shadows, noise or transparency, or AA in the main prefs.
__________________
Matthew O'Neill
www.3dfluff.com
 
  02 February 2013
Thank you guys, I've already tried everything and nothing worked.
I've installed also R13 to see if the problem was still there, I've found no slowdown in R13 and I've looked at program preferences.
This is what I've found, in R13 the program says that my graphic card does not support enhanced openGL, but I can leave standard openGL on without any slowdown.
In R14 the program says that my graphic card has all the extensions to run enhanced openGL but in reality everything is very slow with both standard and enhanced openGL, if I completely disable openGL I've slightly better performance but it's not good enough to work.
It seems all depends on the drivers, in R13 the program uses an ATI 2.1 driver while in R14 uses an APPLE 3.2 driver.
Now my question is, can I choose the old ATI driver in R14? And if so, how?
 
  02 February 2013
You can't use an older driver, but you can force CINEMA 4D to only use an older OGL version.
You have to start CINEMA 4D with the following commandline option
-openglversion=210
This will force OGL version 2.10 to be used.
Hope this helps
Björn
__________________
- www.bonkers.de -
The views expressed on this post are my personal opinions and do not represent the views of my employer.
 
  02 February 2013
Thank you very much Björn, I think this may be a solution. Unfortunately I don't know how to start Cinema with a command line option.
So far I'm only able to start from command line:
-CINEMA 4D
-Contents
-MacOS
-CINEMA 4D

Can you explain in detail how to do it?
Thanks again
 
  02 February 2013
Sorry, OS X and commandline are not my forte.
I found this information regarding starting CINEMA 4D with a commandline option under OS X
/Applications/MAXON/CINEMA\ 4D\ R14/CINEMA\ 4D.app/Contents/MacOS/CINEMA\ 4D -openglversion=210
__________________
- www.bonkers.de -
The views expressed on this post are my personal opinions and do not represent the views of my employer.
 
  02 February 2013
Ok, thanks anyway. Maybe somebody at Maxon can help me, witch is the fastest way to get in contact with support?
 
  02 February 2013
Originally Posted by sirio: Ok, thanks anyway. Maybe somebody at Maxon can help me, witch is the fastest way to get in contact with support?

The support form on the website, but this is not CINEMA 4D specific. Anyone with a bit of detailed OS X knowhow regarding the console should be able to help you.
__________________
- www.bonkers.de -
The views expressed on this post are my personal opinions and do not represent the views of my employer.
 
  02 February 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:58 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.