mmRegions: A small free tool for render region management

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  10 October 2012
Originally Posted by pokoy: Another request here:
Ability to tile a region and to send those tiles to network. So let's say I draw a region, then specify how this region will be tiled, for example 3 x 3 tiles (with an overlap that you'd also be able to specify in pixels). The script would then send 9 jobs to backburner.
This is useful when you render very highres images and only want to rerender a region using the whole farm, not only one server.
That would be awesome, right now I'm doing this manually and it's obviously a bit tedious.


Just wondering, can't you use the 'split scanlines' option of backburner for this?
 
  10 October 2012
I had so many problems using that option in the past so I didn't touch it for several years now, might be an option indeed. Will test, thanks!
 
  10 October 2012
Update: V1.1 Released.

New Features:
  • Preview window now correctly matches render aspect.
  • Now works with V-Ray Frame Buffer regions. If the V-Ray VFB region mode is enabled, creating a new region, restoring a region or batch-rendering will affect that instead of the standard 3dsmax render region.
  • Added spinners for editing the dimensions of the currently selected region.
  • Added option to export/import region data. Data can be exported either as plain text, or as
  • Adobe After Effects keyframe data.
  • Added a confirmation window when ‘delete region’ is pressed.

download: http://www.monotoneminimal.com/archives/450

Last edited by lo : 10 October 2012 at 04:20 PM.
 
  11 November 2012
Most excellent update.
I noticed however a little issue with the Adobe Keyframe data, or rather, with the X and Y value inside the tool itself.

The mmRegion tool says a region in the uppermost left corner is [1,1], while the native sub region settings use the value [0,0] for this. If I export this region data as an AE keyframe data (and likely the generic format as well) it means the exported value becomes [1,1]. AE treat this as one pixel away from the border which leaves a small gap between the region and the edge of the composition. It seems like I cannot set mmRegion to [0,0], and [1,1] is the minimum.

Would this be easy to fix?
 
  11 November 2012
Yes, I will fix it.
 
  11 November 2012
It's been fixed, you can re-download.
 
  11 November 2012
Highly appreciated.
 
  11 November 2012
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:24 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.