CGTalk > Software > Autodesk Maya > Maya Rendering
Login register
reply share thread « Previous Thread | Next Thread »
 
Thread Tools Search this Thread Display Modes
Old 11-04-2013, 04:18 AM   #1276
refract
Expert
 
refract's Avatar
portfolio
John John
Character modeling, Lighting, Compositing
Work
Los Angeles, United States
 
Join Date: Mar 2003
Posts: 713
Send a message via ICQ to refract Send a message via AIM to refract Send a message via MSN to refract Send a message via Yahoo to refract
 
Old 02-24-2014, 03:00 PM   #1277
Sielo90
New Member
portfolio
 
Join Date: Feb 2014
Posts: 1
Maya 2014 Issue

A know this topic is a bit old and i hope someone will read this!

I tried the script in maya 2012 in it works great!

But in Maya 2014 it doesn't work well! Someone have figured how to fix that?

To be more specific it doesn't create the different shaders

(i'm a newbie not good with MEL scripting)

Last edited by Sielo90 : 02-25-2014 at 01:18 PM.
 
Old 03-08-2014, 04:09 AM   #1278
gdepena
New Member
portfolio
Gregory De Pena
Principal Architect
Design OPERA, Inc.
San Diego, USA
 
Join Date: Sep 2012
Posts: 10
[QUOTE=The information presented in Alex Alvarez's DVDs is almost identical to all the vast information in this thread, as well. So let's just give Tastao_Wayne the credit he deserves, and move forward. [/QUOTE]

fyi, Alex Give's Credit to Tastao_Wayne in his Tutorial Series!
 
Old 06-26-2014, 05:27 PM   #1279
SeniorAdrian
New Member
 
SeniorAdrian's Avatar
portfolio
Cluj-Napoca, Romania
 
Join Date: Jun 2014
Posts: 2
Quote:
Originally Posted by Sielo90
A know this topic is a bit old and i hope someone will read this!

I tried the script in maya 2012 in it works great!

But in Maya 2014 it doesn't work well! Someone have figured how to fix that?

To be more specific it doesn't create the different shaders

(i'm a newbie not good with MEL scripting)

Same problem here man im using Maya 2013.It dosent create the shaders.Im freaking out.The leafs come out as white.
 
Old 06-26-2014, 05:58 PM   #1280
SeniorAdrian
New Member
 
SeniorAdrian's Avatar
portfolio
Cluj-Napoca, Romania
 
Join Date: Jun 2014
Posts: 2
Script shader problem.

Hi guys im having a problem with the script.It dosent render the shaders when i hit apply they come out as pure white in the render view.Anyone know how to solve this issue?Im using Maya 2013.
 
Old 06-27-2014, 05:43 PM   #1281
InfernalDarkness
Madness. Madness, I say!
 
InfernalDarkness's Avatar
portfolio
Sho Pi
CG arch/viz
Seattle, USA
 
Join Date: May 2008
Posts: 5,625
Many things change or are broken as versions progress. I still use 2012 for my arch/viz work, but am slowly phasing into 2015. 2013 and 2014 broke instancing if I recall, and were therefor useless for my personal artwork. 2014 even demolished my previous 2012 install on one machine.

I hate to say it, but sometimes the "fix" is just to use the version of Maya that works. :(
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 10-23-2014, 10:40 PM   #1282
JesusFerC
Veteran
 
JesusFerC's Avatar
portfolio
Jesus Fernandez Calderon
Digital Artist
Nemesis Software
San Jose, Costa Rica
 
Join Date: Jun 2009
Posts: 38
Hi guys!, For the ones saying that the info in my tutorial is to close to alex one its true but it was not done on the same page, and not at least as a source for that been the matter, I went to the tutorial after I did mine sadly, most of my info was taken from this post actually, my source its not the tutorial from Alex, which is great, my source is the same as Alex, its a post right here on cg talk, http://forums.cgsociety.org/showthread.php?t=804892, here you can find all the info for both tutorials, the tecniques are almost the same the Alex tutorial is from 2012 if Im not mistake and this post started on 2009, also the biggest difference with my tutorial is the shading part, and part of the process of my tutorial was done with the help of Alex Sandri http://alex-sandri.blogspot.com/ , http://forums.cgsociety.org/showthr...p?f=87&t=922792, tecnique wich I depured, also the scripts can also be found on the cg talk post.

Alex Sandris tutorial was the one that help me alot here and on this process, also, this tutorial is really outdated now, beacuse of the xgen now on maya and the new mila shaders , this make this tutorial almost obsolete now.


Sorry If its looks to similar to the tutorial of Alex, Im aware of that, but it was not a source here, and mine is free....
 
Old 10-23-2014, 11:00 PM   #1283
InfernalDarkness
Madness. Madness, I say!
 
InfernalDarkness's Avatar
portfolio
Sho Pi
CG arch/viz
Seattle, USA
 
Join Date: May 2008
Posts: 5,625
Hi Jesus, are you able to output render passes (CameraDepth, for example, or z-depth) with Xgen instances? I'm stuck so far, tried several other suggestions but cannot even get a Master Beauty pass to work.
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 12-29-2014, 09:54 AM   #1284
sumanbag
New Member
portfolio
 
Join Date: Dec 2014
Posts: 2
Exclamation Problem Installing "djPFXUVs" script in maya

I`m facing problem installing the "djPFXUVs.py" script by DJX. it`s returing me an error saying "syntax error" please help me how to install it properly. thanks in advance.
 
Old 08-02-2015, 07:36 PM   #1285
Dangertaz
Expert
portfolio
Chris
clawson, USA
 
Join Date: May 2009
Posts: 201
Has any one had luck with the new MILA shader for leaves?

My render times are faster with it but I don't understand how to make the translucency behave properly. With an MIA material, I would pipe in my diffuse map texture into a multiply node and connect that to Translucency. I would also keep the weight at 1 and keep transparency between .25 and .4.

Has any one tried to make a leaf or bark shader with a MILA?
 
Old 08-04-2015, 03:26 AM   #1286
InfernalDarkness
Madness. Madness, I say!
 
InfernalDarkness's Avatar
portfolio
Sho Pi
CG arch/viz
Seattle, USA
 
Join Date: May 2008
Posts: 5,625
I'm sorry, Sumanbag and Dangertaz. I've not used that script, nor have I really touched the MILA shaders yet. The mia_mat_x and _passes are still my go-to shaders for both art and arch/viz, although I'm working on a switch to Arnold or Vray sooner or later.

Meanwhile, I felt all artsy again today and checked on CreativeCrash for anything new and "tree" related, for Maya. I found these two scattering scripts, which I'm not sure we've gone over here in this thread. Standalone, not so great, but in conjunction with spPaint3d, they should be pretty helpful.

This one allows you to use textures to control the placements, via particle instancing:

Environment System Script





And this one is similar, but with some other features and no (apparent) texture management. Based on verts only, I believe, but in some cases that may be helpful:

polyScatter



And a quick test using the first one:

__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 09-16-2016, 06:16 PM   #1287
Geuse
Expert
 
Geuse's Avatar
portfolio
Dag
Sweden
 
Join Date: Apr 2006
Posts: 531
Send a message via MSN to Geuse
Hello. I'm trying my hand at creating and evaluating different ways of creating dynamic(or at least moving) grass in Maya.

These are two examples using the oldie, but goldie proven Maya Fur which for my purposes would work just fine as I'm creating a stylistic scene and it renders fast too. But observe, no interpolation in the animation! Not exactly sure where to change that though so any tips are more than welcome.



Next idea I had was to actually scatter clumps of poly grass with the benefit of having textured grass. Then filling the Surface wit nHair and connect it to the clumps using wire deformer. This technique will most likely be too draining and inefficient on any system when implemented on a large scale. Also as they're wire deformed, the polygons themselves will squash and stretch, but when used slightly you won't notice. Kinda like the lattice deformer technique for leaves on trees.




Then there's Xgen and I'm sure you can connect nHair the same way you can with Fur, but it seems the performance is not as fast. Correct me if I'm wrong cause I'm still learning about Xgen, trying to wrap my head around it.

Then there's Vray Fur(or grass) which seems to have its own dynamic simulation incorporated, but I would most likely want a setup that can be rendered in any renderer.

And of course yeti which would be a no brainer to create grass with and connect a dynamic system to.
 
Old 09-17-2016, 04:47 PM   #1288
InfernalDarkness
Madness. Madness, I say!
 
InfernalDarkness's Avatar
portfolio
Sho Pi
CG arch/viz
Seattle, USA
 
Join Date: May 2008
Posts: 5,625
Here is a recent example (unfinished personal work) using Environment System in conjunction with spPaint3D for hero plants and rocks:

__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 09-18-2016, 02:33 PM   #1289
Geuse
Expert
 
Geuse's Avatar
portfolio
Dag
Sweden
 
Join Date: Apr 2006
Posts: 531
Send a message via MSN to Geuse
Looks great, InfernalDarkness!
How many variations of each plant and tree are you using?
 
Old 09-18-2016, 08:05 PM   #1290
InfernalDarkness
Madness. Madness, I say!
 
InfernalDarkness's Avatar
portfolio
Sho Pi
CG arch/viz
Seattle, USA
 
Join Date: May 2008
Posts: 5,625
Thanks!

I usually only do 2 or 3 of each plant, young, medium, old kinda thing. Most of them I make in Onyx still, then adjust them in Rhino before exporting as .obj files over to Maya for texturing. I should be using proxies more but this scene started out as just a test and kinda got out of hand. Some plants you only really need one instance of, to make things work.
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
reply share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:33 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.