CGTalk > Software > Autodesk Maya > Maya Dynamics
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 06-01-2013, 12:28 AM   #1
Haas
Explorer
portfolio
USA
 
Join Date: Jun 2013
Posts: 20
Particles fueled by greenscreen?

Hey,

I'm working a sci fi film where I'm trying to have particles form into a person. I attached the green screen footage to a plane with an image sequence and set as a goal. I'm having trouble controlling the flow of the particles. I tried using an automated ramp as opacity map and using the footage as a texture color for the particles. Any ideas or tips would be appreciated. Thanks in advance.

-mike
 
Old 06-03-2013, 03:49 PM   #2
Duncan
Expert
 
Duncan's Avatar
Duncan Brinsmead
Principal Scientist
Autodesk
Canada
 
Join Date: Jun 2002
Posts: 2,984
Perhaps you might find it easier to emit from the green screen image(textured emission rate) with the image sequence reversed then playback your finished animation in reverse.
 
Old 06-04-2013, 03:07 AM   #3
Haas
Explorer
portfolio
USA
 
Join Date: Jun 2013
Posts: 20
Good idea. Thanks. Ill give it a go. I'm having a hard time applying file node color(texture) to drive the color of nparticle. I dropped the file image sequence into the texture rate and clicked the box enable texture rate. It sets the particles to the keyed out movement of actress but I'm having a hard time getting the color of her clothes, skin, etc. to transfer to particle color. Am I missing a step? I'm scouring the web looking for tutorials. Still a newbie
 
Old 06-04-2013, 11:47 PM   #4
Duncan
Expert
 
Duncan's Avatar
Duncan Brinsmead
Principal Scientist
Autodesk
Canada
 
Join Date: Jun 2002
Posts: 2,984
The default nParticle setup has rgbPP connected to by the internalColorRamp. If you just rightMouse over rgbPP in the Per Particle Attributes and do break connection it should work fine.

You could also instead set colorInput to constant, which breaks the connection, but it also deletes the rgbPP attribute so you would then need to also recreate it( Add Dynamic Attributes, color button).

This all assumes you've also mapped particleColor on the emitter and enabled inheritColor.
 
Old 06-05-2013, 12:29 AM   #5
Haas
Explorer
portfolio
USA
 
Join Date: Jun 2013
Posts: 20
Thanks Duncan. Yeah I forgot to enable color. I appreciate it.
 
Old 06-05-2013, 12:29 AM   #6
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:23 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.